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Opcode Tech Primer

 

Music Software is a very powerful and sophisticated tool and 
Opcode is the industry leader in reliability and ease of use. But as 
with any software, technical difficulties can arise in the course of 
operating our programs. Most of these problems can be traced to one 
or more of several basic causes, and the following information and 
procedures have been found to resolve a large majority of people’s 
questions and technical difficulties. We ask that you go through 
these things thoroughly before contacting Technical Support, as in 
many cases you’ll be able to solve your own problem and get back to 
making music right away—without even having to call us or log 
onto our Web site.
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CH 1: WHERE THE SOFTWARE IS 

 

INSTALLED

 

The most basic information you need to be aware of when using any 
program is which files are installed and where they reside on your 
hard disk.
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Important OMS files and folders installed to your hard disk include:

• The 

 

OMS Setup

 

 application is installed into the “OMS Applications” 
folder, which resides in the “Opcode” folder on the top level of your 
hard disk.

 

NOTE: If installing from an OMS disk set, the OMS Applications folder is 
placed on the top level of your hard disk (not in the Opcode folder).

 

• The “OMS Folder” is installed into the System Folder. The OMS 
Folder contains MIDI interface drivers, Factory Names documents, 
the OMS Time Manager, and OMS preferences.

• The 

 

Open Music System

 

 extension is installed into the Extensions 
folder within the System Folder. OMS applications will not run with-
out this extension installed.
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Installed files for Galaxy and Galaxy Plus Editors include:

• A Galaxy folder containing the application, along with Librarian and 
Editor modules, is installed into the Opcode folder, on the top level 
of your hard disk.

•

 

Galaxy Setup

 

 and 

 

Galaxy Librarian Modules

 

 files are written into your 
System Folder.

• The 

 

Galaxy Keywords

 

 file is written into the Preferences folder inside 
your System Folder. 
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Installed files for these applications include:

 

• A folder containing these applications and their related files is 
installed into the Opcode folder, on the top level of your hard disk.

• Preference files are written into the Preferences folder within the 
System Folder.

• In order to display and print music notation, the 

 

Alois

 

 and 

 

Aloisen

 

 
fonts are installed into the Fonts folder of the System Folder.

 

?

 

NOTE: There is a complete graphic depiction of installed files (and 
where they reside) in the “Quick Start” card included with most 
Opcode applications.
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CH 2: WHAT TO DO WITH OLDER 

 

SOFTWARE VERSIONS

 

If you have older versions of Opcode applications installed there are 
several things to keep in mind.

You can only have one version of OMS installed at a time. Because it 
uses a System extension, multiple versions of OMS can conflict with 
one another and cause serious MIDI communication problems. If for 
some reason you have multiple copies of OMS on your computer, 
you should trash the older OMS files (OMS Folder, OMS Setup 
application, and the Open Music System extension) to eliminate any 
possible conflicts with the current version. 

 

?

 

NOTE: The OMS extension used to be named “Opcode MIDI Sys-
tem.” If this version is present you should remove it. 

 

With the exception of OMS, you can leave old versions of the soft-
ware on your system if you want. Opcode applications generally 
have no interaction with earlier versions—it’s as if you have two 
entirely different programs on your computer. However, most 
people find it less confusing to have just one version of an 
application on their computer. To remove an older software version, 
simply go to the folder (outlined in Where the Software is Installed 
(pg. 1)) and drag the application and its related files to the trash. 

 

Authorizations

 

 are separate from installations. The authorization to 
run a particular version of a program is installed on your computer 
separately and applies only to that version. This means that as long 
as you don’t deauthorize a particular version of a program you can 
trash all the files and reinstall them as many times as you want with-
out affecting your authorization. If you want to move your software 
to a different computer (or hard disk), make sure to first deauthorize 
your hard disk with the 

 

Deauthorization

 

 program located on 
disk 1(key disk).



 

Ch 3: The functional relationship between OMS, Galaxy/GPE, and Vision/SVP/Overture- 4 - Opcode Tech Primer

 

CH 3: THE FUNCTIONAL 
RELATIONSHIP BETWEEN 
OMS, GALAXY/GPE, AND 

 

VISION/SVP/OVERTURE

 

The Open Music System (OMS) keeps track of which MIDI devices 
you have, how they are connected, and which patches (sounds) they 
are using. OMS also makes it easy for music applications to commu-
nicate with MIDI hardware connected to your computer. 

OMS stores information about your MIDI devices in Studio Setup 
documents, which are edited in the OMS Setup application. An OMS 
Studio Setup that accurately reflects your physical studio configura-
tion, and which responds correctly in “Test Studio” mode (see MIDI 
Communication Problems (pg. 8)), is the first and most essential 
component of your MIDI system.

Galaxy is patch librarian software that can retrieve, store and orga-
nize your synthesizer patches. Galaxy stores patches in Bundles, 
which in turn provide patch names to applications like Vision, 
Studio Vision and Overture. Although Galaxy works with hundreds 
of devices, not all instruments are supported.

If your device is not specifically supported by Galaxy and you 
would like to view patch names in Vision (or Studio Vision, Over-
ture) you have the following options:

• OMS provides a number of factory names documents. These docu-
ments, which are stored in your OMS Folder, are typed-in lists of 
stock factory patches; this means however that you can’t alter the 
patches in the device or change their ordering.

• Another option is to create a custom names document. To do this 
open the Names Window (accessed from either the Windows menu 
in Vision/Studio Vision or the Options menu in Overture) and type 
the appropriate patch names into the provided template.

Galaxy Plus Editors does everything Galaxy does and adds on-
screen graphic editing of synth sounds. Not all devices supported 
with a Librarian module in Galaxy have a corresponding Editor 
module in Galaxy Plus Editors.
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You will spend most of your time using Vision, Studio Vision, and 
Overture for writing and arranging music. They utilize the informa-
tion from your OMS Studio Setup and Galaxy Bundles. Once you 
have successfully configured your OMS Studio Setup and loaded 
Galaxy Bundles from your various MIDI devices, it is not necessary 
to actually run those applications. You can open your OMS Studio 
Setup from within Vision/Studio Vision in the 

 

Setups

 

 menu and 
from Overture in the 

 

Options

 

 menu. In addition, choose 

 

Win-
dows>Names

 

 in Vision/Studio Vision (or 

 

Options>OMS Names

 

 in 
Overture) to subscribe to a Bundle or Names document in order to 
get patch names.

Keeping in mind the functions of the various programs, and their 
relationship to one another can often help you focus in on where a 
particular problem may be occurring. For instance, if you are in 
Vision and you are not getting a MIDI signal in or out of a device, the 
first place to check is OMS, since it is mainly responsible for MIDI 
management. Or, if you are having trouble with a particular Bundle 
in Overture, the first thing to try would be to launch Galaxy and see 
if the same problem happens there, since Galaxy is responsible for 
handling patch information.
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CH 4: BASIC TROUBLESHOOTING 

 

STEPS

 

EXTENSION CONFLICTS

 

A very large percentage of the problems people have with their Mac-
intosh software result from a conflict between their various System 
extensions. Extensions are programs or parts of programs that are 
automatically loaded into RAM when you turn on your computer—
they appear as little puzzle-piece icons at the bottom of your screen 
when you boot up. In general, it is best to run with as few extensions 
as possible to avoid conflicts.

Macs running system 7.5 or later come with the 

 

Extensions Manager

 

 
control panel; if you uncheck an extension listed there and then 
restart the computer, it will not be loaded into RAM and therefore 
cannot conflict with another extension. 

 

?

 

NOTE: Macs with earlier versions of the System software can 
accomplish the same effect by dragging an extension from the 
Extensions folder (located in the System folder) to any other location 
on your hard disk. There are also several commercial startup manag-
ers that will perform this same task.

 

For using Opcode software, you only need two or three active 
System extensions. The first of these is always necessary, and that is 
the 

 

Open Music System

 

 (OMS) extension. If you are working with 
MIDI only (no digital audio), OMS is the only extension you need to 
run most Opcode applications. If however you intend to use digital 
audio, you will need either Apple’s 

 

Sound Manager

 

 extension or, if 
you are using Digidesign audio hardware, the 

 

DigiSystem INIT

 

. In 
addition, if you are using a MIDI card or interface with an Opcode 
application that requires an extension, such as Digidesign’s Sample-
Cell, you will need to retain those extensions as well. You will also 
need your printer driver installed if you intend to do any printing.
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Of course, it is ultimately up to you as to which extensions you want 
active. However, if you are experiencing problems while using our 
software and are going to contact Technical Support, we ask that you 
first disable all other extensions besides the Open Music System, and 
your audio extension if you are using one, and restart your computer 
to see if the problem is resolved. If it is, then there is an extension 
conflict and you will need to either run with a reduced set when 
using our software, or systematically go through your extensions, 
loading them in groups, to try and locate the conflict.

 

CORRUPTED PREFERENCE FILES

 

Occasionally, an application’s preference file(s) can become cor-
rupted, usually resulting in small glitches or strange performance in 
a previously functioning program. If these files are trashed or moved 
when the program is not running, they will be recreated clean when 
you relaunch the application.

For Vision, Studio Vision and Overture, these files reside in the Pref-
erences folder inside the System Folder and are called 

 

Vision 
Preferences

 

 (or Studio Vision Preferences or Overture Preferences). If 
you develop an odd or anomalous problem with an application, 
simply quit the program and drag the file from the Preferences 
folder to the desktop; then reopen the program to see if the problem 
is resolved. If it is, then there was some file corruption in the prefer-
ences and you can drag it to the trash. You will however have to 
reset a few of your application’s parameters (Metronome’s MIDI 
note assignment, for example). If the problem was not solved then 
simply drag the old preferences file (from the desktop) back into the 
Preferences folder and continue troubleshooting.

 

?

 

NOTE: Once you’ve configured your application to your liking, it is a 
good idea to make a copy of your preferences file and save it to a 
floppy disk. That way if you later need to trash the file due to corrup-
tion, you can simply replace it with the backup—thereby saving you 
from resetting your preferences in the application. 
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In Galaxy or Galaxy Plus Editors the files in question are 

 

Galaxy 
Setup

 

 and 

 

Galaxy Librarian Modules

 

 in the System Folder, and 

 

Galaxy 
Keywords

 

 in the Preferences folder. If there is a particular Bundle that 
has developed a strange problem or won’t load patches correctly, 
you can try quitting the application and removing these files. When 
reopening Galaxy you will see a “Scanning” dialog, which means 
that your OMS Studio Setup is being scanned so the relevant mod-
ules are automatically reinstalled.

 

?

 

NOTE: If you have a K2000, you may not want to immediately trash 
the Galaxy Setup file since it stores important ROM information. 
Instead place Galaxy Setup on your desktop to see if the new file 
alleviates the problem —if not, drag the old Setup file back into the 
System Folder.

 

?

 

NOTE: If you have been assigning keywords to patches, it would be 
better not to actually trash Galaxy Keywords. Just move it out of the 
folder to see if it fixes the problem. If not, simply drag the old Key-
words file back into the Preferences folder.

 

REINSTALLING APPLICATION SOFTWARE

 

If disabling extensions or trashing preference files does not solve 
your problem, it is sometimes a good idea to trash all application 
files and do a fresh install from the floppy disks (or CD-ROM). This 
will eliminate any corrupted application files and restore you to an 
original “clean” state. Remember to store any files you have made 
with the application (sequences, Studio Setups, Overture files or 
Galaxy bundles) separately from the application so you don’t acci-
dently throw out something you want to keep. 

 

?

 

NOTE: You do not need to deauthorize the application because its 
authorization key remains on your hard disk until you run the Deau-
thorize application.

 

MIDI COMMUNICATION PROBLEMS

 

Many problems with MIDI software revolve around not getting 
input from a controller to the software, or not getting output from 
the software to a MIDI device. These are MIDI communication errors 
and are probably due to one of several causes.
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CURRENT

 

:

 

• Thoroughly examine your Studio Setup to make sure all of your 
devices are properly defined and depicted. Pay special attention to 
whether the INs and OUTs for all devices (virtual “patch cords” with 
arrowheads) reflect the physical patch cords of your actual studio. 
Also, double-click on the device icon to open the MIDI Device Info 
Window and check that each device is set up to receive on the appro-
priate MIDI channels, and that you have established whether it is a 
controller and if it is multitimbral. It is especially good to check these 
things if you haven’t been using the program for a while, or if you 
have opened an old Studio Setup with a later version of the program, 
as it is easy to forget about changes in your studio that may not be 
reflected in your OMS Setup.

• Make sure there is a small diamond next to the name of the Studio 
Setup name in the window’s title-bar, thus indicating that it is the 

 

current

 

 Setup document. If there isn’t a diamond, choose 

 

File>Make 
Current

 

.
• Choose 

 

Studio>Test Studio

 

 to verify MIDI input and output. Once 
enabled, move the cursor over one of your device icons and notice 
the cursor turn into a small note (if it doesn’t, verify that 

 

Studio>Test Studio

 

 is checked); then single-click on the device and 
you should hear random bursts of MIDI notes from that instrument 
(this can be quite loud so make sure your volume is down). Next 
play some notes on any controller keyboard—you should hear your 
Macintosh say “MIDI received.”

 

Y
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UP
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:

 

• Check and double-check that all devices have the desired MIDI 
inputs and outputs correctly connected to your interface (IN to OUT, 
OUT to IN). 

• If you have a multiport interface (Studio 64X, Studio 4 or Studio 5), it 
is important that just one device is used for each port number—even 
if the device is connected with just one MIDI cable. In other words, 
always treat the paired IN/OUT ports of the interface as though they 
were dedicated to a single device. 

• If the communication problems are with a specific device, try substi-
tuting different MIDI cables to rule out defective cables.

• If the problem was only on playback, check that the device’s volume 
was turned up, and that any mode or other front panel settings, 
which may be necessary to allow the device to send or receive MIDI, 
are correctly configured.
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• Try using a different serial cable.
IMPORTANT: Most interfaces have LEDs that flash on input/output, 
which can help narrow your problem.

• If you’re not getting MIDI playback and the interface’s output LEDs 
are flashing, then the problem must reside in the MIDI cable con-
necting the device to the interface, or in the device itself. If you are 
not getting playback and the interface’s output LEDs are not flash-
ing, then the problem probably resides within the computer (OMS 
problem or extensions conflict) or with the interface itself (try using 
your setup with another interface to test). 

• The reverse is obviously true for problems on recording from a 
sequencer. If you have a record problem and the interface’s input 
LEDs are flashing when you play the controller, then the problem is 
likely with your OMS Setup (or an extensions conflict); if the LEDs 
are not flashing then its probably your device, cables or interface.

YOU MAY HAVE AN EXTENSION CONFLICT:

• Some MIDI communication problems are related to System conflicts. 
See Extension Conflicts (pg. 6) for more details.
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CH 5: MACINTOSH SYSTEM 
ERRORS AND WHAT TO DO 
ABOUT THEM

The Macintosh has a series of numbered error messages that it dis-
plays when encountering a problem. There are several important 
things to know about these messages. First, you should always 
restart your computer when one of these System errors occurs. There 
are a great many of these messages, and often the actual message 
displayed is very cryptic and does not indicate the real problem. 

There are however several basic causes and possible remedies:

• You have an extension conflict. Extension conflicts are the most 
common cause of Mac System errors, particularly positive numbers 
1-100. See Extension Conflicts (pg. 6). 

• The application is running out of allocated memory. Programs claim 
a chunk of your total RAM when launched; if it uses up this RAM, it 
can cause a crash. To allocate more memory, quit the program and 
single-click its icon from the desktop and choose File>Get Info; then 
increase the number in the “Preferred size” field (usually an increase 
of 40-60% will do the trick). This assumes of course that you have the 
available RAM to spare; if not, you may wish to invest in more 
memory for your computer.

• The System software has become corrupted. Apple does recommend 
reinstalling your OS periodically to keep this in check (something 
like getting the oil changed on your car). If your problems are not 
remedied by any of the procedures previously mentioned, reinstall-
ing the OS is often the ultimate solution.

• There is a bug in the application. We test all our applications rigor-
ously, and have a strong Beta-test program, but occasionally 
problems do get through. If you have tried all the above steps and a 
problem persists, we are eager to see if there is a bug with the 
application, and fix it as soon as possible. If you do call with what 
you think is a software bug, it helps us enormously if you can pro-
vide a “recipe” to reproduce the problem (bugs are almost always 
reproducible on a wide range of computer models).
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CH 6: INFORMATION YOU NEED 
BEFORE CONTACTING 
TECHNICAL SUPPORT

If you have been through the above steps and are still experiencing 
problems, please have the following information ready before con-
tacting Tech Support:

CUSTOMER CODE
OR APPLICATION
SERIAL NUMBER

Your customer code is “ZZ,” the first five letters of your last name or 
of the institution that purchased the software, and some number. It 
is created when we receive your registration card and is then printed 
on anything we later send you. If you have not yet registered your 
software, you must provide us with the serial number printed on 
disk 1 of the original version of the program you purchased.

APPLICATION
VERSION NUMBERS

This is essential because certain application versions, or combination 
of versions, can have problems we already know about, which 
means we can often give you a solution immediately. To find the 
version numbers, either look at the disks used to install the software 
you are currently using, or single-click on the unopened application 
icon and choose File>Get Info (or type command-I). It is especially 
important to know your version of OMS as many of what seem to be 
Vision, or Galaxy or Overture problems are really OMS problems.

MACINTOSH
MODEL,

OPERATING
SYSTEM VERSION,

AND RAM SIZE

Many problems are related to specific computers or operating sys-
tems. To find out your version of the Apple System software and 
how much RAM your computer has, choose About this Macintosh 
from Apple menu (with the Finder current).
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CH 7: FREQUENTLY ASKED 
QUESTIONS

Q: WHY AM I HAVING TROUBLE PRINTING WHILE I RUN OMS 
APPLICATIONS?

A: Choose the OMS MIDI Setup menu item and temporarily uncheck 
BOTH serial ports. When the printing job is completed, recheck the 
port(s) for MIDI use.

Q: WHAT DO I DO IF MY MIDI INSTRUMENT IS NOT LISTED IN THE MIDI 
DEVICE INFO WINDOW’S LIST?

A: If your device is not listed in the Manufacture and Model pop-ups 
of the MIDI Device Info Window, you can still add it to your OMS 
Studio Setup and use it with OMS applications. 

a Choose Studio>New Device to open the MIDI Device Info Window.

b In the Manufacturer pop-up choose Other (if the Manufacturer is not listed); then in 
the Model pop-up select Other.

The choice “Other” should be at the top of both of these pop-up menus. 

c In the Name field, below Model, type in the desired instrument name. 

Your OMS applications will reference this device by the name you enter.

d Lastly, specify receive channels, sync options, and whether the device is a 
controller and if it is multitimbral.

Q: WHY IS MY INTERFACE’S RED INPUT LED CONSTANTLY FLICKERING 
OR PULSING FAINTLY.

A: Many newer MIDI devices send out a message called Active Sens-
ing, which tells devices (to which they are connected) that they are 
online and ready to go. This creates a faint red LED pulse on your 
interface, even when you are not playing.



Ch 7: Frequently Asked Questions - 14 - Opcode Tech Primer

Q: CAN I GET PATCH NAMES IN VISION FOR MY DEVICE EVEN THOUGH IT 
ISN’T SUPPORTED BY GALAXY?

A: Yes. To create a custom name list, follow these steps:

a Define the device in your OMS Studio Setup and activate Test Studio to make 
sure the device is sending and receiving MIDI signals. 

b In Vision, or Studio Vision, choose Windows>Names to open the Names Window.

c Highlight the desired device and choose Names>New Patch Document.

If your device is not listed, make sure your current Studio Setup contains the 
device.

d Single-click on the Patch Name column for the first patch number (defaults to 
number 0) and type in a patch name.

Repeat this procedure for all the patches you wish to have listed in the Names 
document. 

e Once you have entered all the patch names, click OK and then Save.

The new Names document is then saved and automatically subscribed. The 
device’s patch names then appear in Vision’s Current Patch field (next to the trum-
pet icon).

Q: WHAT ARE THE REQUIREMENTS TO SUPPORT A NEW MIDI DEVICE IN 
GALAXY?

A: To support any new MIDI device takes many, many engineering 
hours to work with the device in house and develop a new Galaxy 
module. In order to justify those engineering hours, Opcode has four 
major requirements:

• The device must be selling well, to many users, for us to have a large 
enough customer base to support it.

• We need the cooperation of the manufacturer to provide us with at 
least one loaner unit along with its system exclusive specs.

• The unit should be highly programmable. We don’t get many 
requests to support units that use mostly presets with just a few edit-
able parameters.

• We also factor in how many requests we get from users to support 
the device.
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Q: WHY DON’T MY SYNTHESIZER PATCH NAMES FROM GALAXY APPEAR 
IN VISION?

A: A Bundle must be retrieved from your instrument. Then from 
within Galaxy, choose File>Save and Make Current so the patch 
names appear in Vision.

? NOTE: When creating bundles in Galaxy it is sometimes necessary 
to load all banks in the bundle. For instance, if you have not retrieved 
the Proteus Program Map bank, names will not appear in Vision. 

If the patch names still don’t appear after Making Current in Galaxy, 
or subscribing to the Bundle in Vision, your instrument’s Device Info 
may be set incorrectly in the current Studio Setup. If the device’s 
Model is set to “Other” you will be unable to subscribe. Make sure 
the name specified for Model matches the Bundle type to which you 
are subscribing.

Q: WHERE CAN I FIND ONLINE HELP FOR VISION/STUDIO VISION, 
GALAXY AND OMS?

A: Online help is available within most Opcode programs:

• Vision, Studio Vision: Use Command-Shift-Option to click on any 
field, button, icon or menu item for pop-up help on that topic. 

• Galaxy, Galaxy Plus Editors: Open a new Bank, Bundle or Library 
and the Help option in the Apple Help menu (“?”) will tell you 
everything you need to know about using that device. 

• OMS Setup: Incorporates Apple’s Balloon Help; once enabled, 
simply point to any icon in your Studio Setup, or any menu item, for 
balloon help.
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CH 8: BACKING UP YOUR WORK

Please back up your files! The most important rule of working with 
any computer is “back up your data,” whether it’s word processing, 
graphics or music. Back up everything in three locations if possible. 
Floppies, external drives and removable cartridge are excellent ways 
to archive your data. Backing up your work doesn’t take nearly as 
much time as losing a file and “learning the hard way.”

Do a “Save As” every 15 minutes or so and switch to a different disk 
or location. Add the date or version number (2, 3, 4, etc.) to succes-
sive versions when saving and keep some of your previous versions 
as extra “insurance.” By doing this regularly, you will never lose 
more than a few minutes of work. Floppies and cartridges can be 
stored in different locations so if you have a fire or your computer is 
stolen, you still have years of valuable work saved. 

Although digital audio takes a lot of hard disk space, removable car-
tridges and more affordable hard disk prices allow most users to 
regularly back up audio. Digidesign owners can even back up digital 
audio to an audio DAT recorder.

Other files worth backing up include:

• OMS Studio Setup documents;
• Galaxy Bundles, Banks, and Libraries;
• Preference files for Vision, Studio Vision, and Overture;
• Galaxy preference files (including Galaxy Setup, Galaxy Librarian 

Modules, and Galaxy Keywords).
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	b In the Manufacturer pop-up choose Other (if the ...
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