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CH 1: STUDIO PATCHES 

 

INTRODUCTION

 

WHAT ARE STUDIO PATCHES?

 

Studio Patches route (and process) MIDI data to and from instru-
ments contained in your 

 

current

 

 Studio Setup document. Studio 
Patches, which are created and edited with the Studio Patches Editor 
application, are stored in Patch documents on your hard drive.

Each Patch document may contain:

• Up to 128 patches
• Any number of Virtual Controllers
• Any number of Virtual Instruments
• Any number of Program Change Sources
• A Patch Chain

 

Patches

 

 can perform a wide range of MIDI processing and are con-
structed by connecting various modules together in the Studio 
Patches Editor. The patch modules include splitters (for channels, 
note range, and velocities), modifiers (for velocity, mono/poly after-
touch, and controller values), a transposer, and a control number 
mapper. The various patch modules are discussed in Chapter 2: 
Patch Modules.

 

Virtual Controllers

 

 and 

 

Virtual Instruments

 

 are extremely power-
ful features of Studio Patches. A Virtual Controller is the output of a 
MIDI device plus some form of MIDI processing. A Virtual Instru-
ment is some form of MIDI processing routed to one or more MIDI 
devices. Virtual Controllers and Virtual Instruments can be valuable 
aids for both sequencing and live performance. They’re discussed in 
Chapter 3: Virtual Controllers and Virtual Instruments.

 

Program Change Sources

 

 allow you to specify various ways to 
change Studio Patches. They’re discussed in Chapter 4: Program 
Change Sources.

A 

 

Patch Chain

 

 is a sequence of patches that can be stepped through 
with a MIDI controller, or with the Studio 5’s optional footswitches.
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Patches are strictly real-time, live-playing MIDI connections; they do 
not actually affect the MIDI data that an application sends or 
receives. MIDI applications will always receive from the sources to 
which they are connected and be able to send to any destinations, 
regardless of what the current patch does.

 

?

 

Since most sequencers provide MIDI thruing (routing) from within the 
application, you may wish to keep Studio Patch #1 as an “empty” or 
“do nothing” patch for use with sequencer programs.

 

C

 

OMPATIBLE

 

 MIDI
I

 

NTERFACES

 

To use Studio Patches you must have an Opcode Studio 5, Studio 4, 
Studio 64X or Studio 64 XTC. Below are some important details, spe-
cific to each interface, that you should know.

•

 

Studio 5

 

: The Studio 5 has built-in RAM that can store a Studio Patch 
document. This means that the Studio 5 can use Studio Patches 
(recalled from its front panel) without being connected to a 
computer.

•

 

Studio 4

 

: In order to use Studio Patches, this interface must be con-
nected to your Macintosh and an OMS application must be 
launched.
Studio Patch processing occurs in addition to any processing per-
formed by the Studio 4’s Routing, Channelizing and Muting 
Window. When first learning to use Studio Patches, you may want 
to disable all routings in this window.

•

 

Studio 64X, Studio 64 XTC

 

: In order to use Studio Patches, this 
interface must be connected to your Macintosh and an OMS 
application must be launched.
Studio Patch processing occurs in addition to any processing per-
formed by the Studio 64X’s User/Preset Programs, as defined in the 
Program Edit Window. When first learning to use Studio Patches, 
you may want to disable all routings in this window.

 

?

 

NOTE: Although Studio Patches require one of the above mentioned 
interfaces, you can use devices that aren’t attached to your interface 
(such as a SampleCell card) in Patch documents.
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PATCH DOCUMENTS

 

This section discusses the terminology and techniques for working 
with Patch documents. 

Balloon help is available from the Studio Patches Editor application. 
See your Macintosh documentation if you don’t know how to access 
balloon help. In addition, you can hold down the shift, option, and 
command keys and point to any field, icon, button, or menu item for 
pop-up help.

Open the Studio Patches Editor application by double-clicking its 
icon.

 

O

 

PENING

 

 

 

A

 

 N

 

EW

 

P

 

ATCH

 

 D

 

OCUMENT

 

Open a new Patch document by choosing 

 

File>New Patch Docu-
ment

 

 (or type command-N). 

 

Figure 1: Patch Document Window
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P

 

ATCH

 

 D

 

OCUMENT

 

W

 

INDOW

 

T

 

ERMINOLOGY

 

When you open a new Patch Document Window, you’ll see four but-
tons under the title bar. From left to right these represent Virtual 
Controllers, Virtual Instruments, Program Change Sources, and the 
Patch Chain. Each of these buttons will be discussed later in this 
manual. Below the buttons is a line for the first patch in the docu-
ment. This line consists of a selector dot, a diamond to indicate the 
current patch, the program (or patch) number and a Name/Descrip-
tion field that can hold as much text as needed to describe the 
operation of that patch.

 

Figure 2: Anatomy of a Patch Document Window

 

A

 

Virtual Controllers Button

 

B

 

Virtual Instruments Button

 

C

 

Program Change Source Button

 

D

 

Patch Chain Button

 

E

 

Current Patch Selector

 

F

 

Selector Dot

 

G

 

Current Patch Indicator

 

H

 

Patch Number

 

I

 

Patch Description Field

You can have any number of Patch documents open at one time, but 
only one document can be the 

 

current

 

 Patch document. The current 
Patch document is indicated by a diamond next to its name.

1 2 3 4
5

6
7 8 9
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Figure 3: Indicating Current Patch Document

 

The current Patch document always reflects the exact state of the 
Studio Patches driver. Any changes made to a current Patch docu-
ment take effect immediately in the connected interface.

 

?

 

NOTE: When using a Studio 5, making a Patch document current 
sends the patches in that document immediately to the interface.

 

Patch documents are based on the devices defined in the current 
Studio Setup document. If you make a different Studio Setup docu-
ment current, your current Patch document may not know about the 
devices in the new Studio Setup document. Similarly, the new Studio 
Setup document may not know about the devices referenced by the 
current Patch document.

 

?

 

NOTE: If you create two identical Studio Setup documents, with 
identical names for identical instruments on identical ports, Studio 
Patches will see the devices as different unless you copy and paste 
the devices between the two documents.

Diamond indicates current Patch document

No diamond indicates Patch document is not 
current
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M

 

AKING

 

 P

 

ATCH

 

D

 

OCUMENTS

 

C

 

URRENT

 

Choose 

 

File>Save And Make Current

 

 to make a Patch document 
current.

You’ll see a standard Macintosh “Save As” dialog box. Save the file 
in the same folder as your Studio Patches Editor application. A dia-
mond appears next to the Patch document’s name indicating that it 
is now the current Patch document.

 

?

 

NOTE: If a Patch document has already been saved, the 

 

Save And 
Make Current

 

 command becomes a 

 

Make Current

 

 command. 

 

A

 

DDING

 

 P

 

ATCHES
TO

 

 

 

A

 

 P

 

ATCH

 

D

 

OCUMENT

 

Choose 

 

Patch>New Patch

 

 (or type command-P) to add a new patch 
to the document. 

 

Figure 4: Adding a Patch

 

S

 

ELECTING

 

P

 

ATCHES

 

Unselected patches have a bullet dot to their far left. This is the patch 
selector dot. Selected patches have a small triangle instead of a bullet 
dot.

Click a patch’s selector dot to select a patch; the bullet will turn into a 
triangle.

 

Figure 5: Selecting a Patch

 

Shift-click other selector dots to select additional patches.
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 The diamond to the right of the selector dot is the current patch 
selector. You make a patch current by clicking in the column where 
the diamond would appear, or by selecting a patch and choosing 

 

Patch>Recall Patch

 

 (command-R).

The current patch is the patch that is being used by Studio Patches 
and the connected interface.

 

Figure 6: Making a Patch the Current Patch

 

C

 

OPYING

 

 

 

AND

 

P

 

ASTING

 

 P

 

ATCHES

 

You can copy and paste patches to new locations. If, in the following 
example, you wanted to copy patch #3 as the basis for building a 
new patch, you would:

 

a

 

Click Patch #3’s selector dot to select it and then choose 

 

Edit>Copy

 

.

 

b

 

Choose 

 

Edit>Paste

 

.

Patch #3 is copied to the next available patch location which, in this case, is 
Patch #4. Patch #4 is now an exact duplicate of Patch #3.
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Patches can also be cut to the Clipboard, for pasting to another Patch 
document, or cleared.

? NOTE: When a Patch Document Window is active, the Paste com-
mand always pastes a patch to the first undefined patch. You cannot 
paste a copied patch to an existing patch.

CHANGING PATCH
ORDER

You can rearrange patches by option-click-dragging a patch to a new 
location. In Figure 7, the Patch document shown in A is re-ordered 
by option-clicking Patch 2 (as shown in B), dragging it between 
Patches 4 and 5 (as shown in C), and releasing the mouse (as shown 
in D).

Figure 7: Re-ordering Patches

If you want to view your Patch document in numerical order, select 
Patch>Sort by Patch Number. This places a check mark to the left of 
the option. Patches will always be displayed in numerical order as 
long as Sort by Patch Number is checked. Selecting the command 
again will uncheck it. Patches can be displayed in any order when 
Sort by Patch Number is unchecked.

A

B

C

D
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SEQUENCING PATCH CHANGES

You can switch Studio Patches from an OMS-compatible MIDI 
sequencer.

If Studio Patches is installed, OMS always adds a device called 
“Studio Patches pgm chg” to your Studio Setup document. You can 
send program changes to this device on MIDI channel 16 to change 
the current Studio Patch. The main purpose of this device is to let 
you sequence Studio Patch changes from a sequencer. To do so:

a Launch an OMS-compatible sequencer.

b Choose the “Studio Patches pgm chg” device as the record sequence’s MIDI 
destination.

c Record MIDI program changes into the sequencer.

d Play back the sequence. Studio Patches will change with each MIDI Program 
change.

PATCH EDIT WINDOW

This section discusses the terminology and techniques for working 
with Patch Edit Windows.

OPENING A
PATCH EDIT

WINDOW

Select a patch and choose Patch>Edit Patch, or double-click its selec-
tor dot. A Patch Edit Window will open.

Figure 8: Empty Patch Edit Window

PATCH EDIT
WINDOW

TERMINOLOGY

Figure 9: Anatomy of a Patch Edit Window

Module Icons Patch Editing Area

Modules

Connections (all the connections in the patch editing 
area comprise one “patch.”)
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Figure 9 illustrates a basic Patch Edit Window. The window contains 
a row of module icons across the top of the screen. Each of these 
icons represents a MIDI Source, MIDI Destination, or MIDI Process-
ing module. The row of module icons is called a module palette. The 
patch editing area contains “connections,” each of which comprises a 
MIDI Source module and all modules connected to its right. Any 
amount of MIDI processing can be applied to any connection. A 
patch is made up of all the connections in the patch editing area. 

? IMPORTANT: Since most sequencers control MIDI thruing (routing) 
from within the application, it’s useful to keep patch #1 as an “empty” 
or “do nothing” patch for use with sequencer programs.

CREATING
CONNECTIONS

This section discusses the techniques needed to create connections. 
Don’t worry if you don’t understand the function of each module, 
they’ll be discussed in Chapter 2: Patch Modules. 

a Click the leftmost module icon in the module palette.

This is the MIDI Source (or controller) icon. When you click it, its name is shown to 
the right of the module palette.

b Move the cursor into the patch editing area.

The cursor becomes a MIDI Source module icon.

c Click in the patch editing area to create an undefined connection.

A connection appears as a selector dot along with some number of connected 
modules. Every connection needs both a MIDI Source and a MIDI Destination 
module (MIDI Source and Destination modules are explained in Chapter 2: Patch 
Modules). When a MIDI Source module is first placed in the patch editing area, 
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both an undefined MIDI Source module and an undefined MIDI Destination module 
appear. Each module contains a question mark until you choose a device from its 
pop-up menu.

d Click on the triangle to the right of the MIDI Source module’s question mark to see 
a pop-up menu of devices defined in your current Studio Setup document.

Select a device from the pop-up menu.

e Click the pop-up menu in the MIDI Destination module and choose a destination 
device.

You’ve created a simple connection; the K2000 sends MIDI data 
directly to Channel 1 of the CZ-101. When you play the K2000, the 
CZ-101 will play on MIDI Channel 1.

ADDING MIDI
PROCESSING

Use MIDI processing modules to filter, split, transpose, modify or 
map MIDI data in a variety of ways. In the following example, you’ll 
add a Velocity Modifier module to your connection. Velocity Modi-
fier modules (and other MIDI processing modules) are discussed in 
Chapter 2: Patch Modules.
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a Click the Velocity Modifier module icon (the little hammer) in the module palette. Its 
name is shown to the right of the module palette.

b Move the cursor into the patch editing area. The cursor will become a Velocity 
Modifier module icon (little hammer).

c Position the cursor over the space between the MIDI Source and MIDI Destination 
modules. The area becomes highlighted.

d Click the mouse to insert the module.

SELECTING
MODULES AND
CONNECTIONS

You can select a module or group of modules for cutting, copying, or 
pasting. To select a module, click anywhere within it that isn’t a con-
trol (like a device menu or channel numerical). A selected MIDI 
Source or MIDI Destination module will have a thick border. A 
selected MIDI processing module becomes highlighted.

Figure 10: Unselected Modules

Figure 11: Single Selected Module
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Shift-clicking a second module when one is already selected will 
select the second module and all modules between it and the first 
one.

Figure 12: Shift-Clicking a Second Module

You can also select multiple modules by clicking in the white space 
around them and dragging a rectangle. All modules that intersect 
the rectangle become selected.

Figure 13: Dragging to Select Modules

You can select all modules in a connection by clicking the selector 
dot to the left of the modules.

Figure 14: Selecting All Modules

Command-clicking modules either adds or removes them from the 
selection. An unselected module becomes selected, a selected 
module becomes deselected. In the example, below, command-click 
the Velocity Modifier module to deselect it.

Figure 15: Command-Click to Deselect Modules
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COPYING/PASTING
MODULES AND
CONNECTIONS

You may cut, copy, or clear selected modules. You cannot, however, 
cut or clear a Splitter module if it has more than one output. To 
remove a Splitter module, you must first remove either all or all but 
one of its outputs.

You can paste a copied module to a new location by clicking the 
desired location and selecting Edit>Paste. The contents of the Clip-
board are inserted into the selected space.

a Click on the Velocity Modifier module to select it, then choose Edit>Copy.

b Place an insertion point between the Splitter module and the Morpheus 
Destination module by clicking the blank space between them (the space becomes 
highlighted).

c Choose Edit>Paste to paste a copy of the Velocity Modifier module (with all of its 
parameters).

You may copy and paste entire connections without selecting a paste 
destination. The pasted connection appears below all other connec-
tions in the patch editing area.

You may also clear selected modules and connections, or cut them to 
the Clipboard.

CHANGING
CONNECTION

ORDER

You can rearrange the patch editing area by option-dragging any 
connection’s selector dot.

a Option-click the top connection’s selector dot.
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b While still holding the mouse button, drag the entire connection below the lower 
connection. Release the mouse button to see the new connection order.

SOURCE/
DESTINATION

MUTING

You can mute any number of MIDI Source or Destination modules. 
Muting Source and Destination modules allows you to concentrate 
on specific sections of complex patches.

To mute a MIDI Source module or MIDI Destination module, 
double-click its device icon. The module is dimmed. To unmute the 
module, double-click its device icon again.

As an example, suppose you have the connection shown in 
Figure 16.

Figure 16: Simple Connection

a Double-click the DR-660 device icon to mute the module. 

When you play the K2000, only the Morpheus is heard.

b Double-click the DR-660 device icon to enable the module, then double-click the 
K2000 device icon to mute that MIDI Source module. 

Anything you play or do on the K2000 is ignored by the Morpheus and DR-660 
modules.

? NOTE: To mute a source or destination, be sure to double-click the 
device icon, not the device name.

The Solo and Unsolo commands in the Patch menu are also useful in 
this regard. Soloing mutes all other destinations in the connection. 
When you are done soloing, choose Unsolo to re-enable all destina-
tions in a patch.
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CH 2: PATCH MODULES

This chapter describes how to configure and use each of the modules 
in the Module Palette.

Figure 17: Anatomy of a Module Palette

MODULE EDITING BASICS

You can edit a module once it’s part of a connection. Adding mod-
ules to connections was discussed in Chapter 1: Studio Patches 
Introduction. To access the editing window of any module (except 
the MIDI Source module, MIDI Destination module, or Simple Split-
ter module) simply double-click the module in a connection.

You can edit most modules using numerical editing techniques (as 
discussed in your OMS manual). You can also edit the following 
parameters from a MIDI controller:

• Control number selection in any highlighted control number pop-up 
menu

• Transposer map note numbers
• Note numbers in a Note Range Splitter module
• Velocity levels in a Velocity Splitter module

Select the device (or devices) you’ll use for MIDI editing by choosing 
Windows>Controllers for MIDI Editing. This produces a dialog 
containing a list of all devices defined in your current Studio Setup 
document. Select (highlight) those items you wish to enable for MIDI 
data entry. If you don’t plan to use a MIDI controller to edit patches, 
it’s best to disable all controllers. That way you can’t accidentally 
edit a module by playing your MIDI controller.

The following sections discuss each module in detail.

MIDI Source
Simple Splitter

Note Range Splitter

Transposer
Aftertouch Modifier

Control Value Modifier
MIDI DestinationEvent Type Filter

Channel Splitter
Velocity Splitter

Velocity Modifier

Poly Aftertouch Modifier

Control Number Mapper

Pitch Bend Modifier



Ch 2: Patch Modules - 17 - Studio Patches Manual

MIDI SOURCE MODULE

Figure 18: MIDI Source Module

As its name implies, a MIDI Source module represents a source of 
MIDI data. Use the MIDI Source module to choose which device’s 
MIDI output you wish to route to other devices. When you first 
insert a MIDI Source module, a question mark appears. To define a 
MIDI Source module:

a Click anywhere to the right of the question mark to open a pop-up source menu.

This menu contains all sources as defined in the current Studio Setup document. It 
also contains any Virtual Controllers that are defined in the current Patch docu-
ment (Virtual Controllers are discussed in Chapter 3: Virtual Controllers and Virtual 
Instruments).

b Choose a source from the pop-up menu to define the MIDI Source module.

A Studio Patches compatible interface can also be a source of MIDI 
data, which can come from timing information (MTC, DTL, DTLe), 
footswitches (FS1, FS2), and foot controllers (FC1). The Studio 5 can 
even act as a note source when Audio In is enabled and in use. Select 
the interface as the MIDI source if you wish to use timing data, foot-
switches, the foot controller, or Audio Input in a Studio Patch.

You can change the source assigned to a MIDI Source module at any 
time by clicking the name and choosing a new source from the 
pop-up menu.

REFERENCING
NON-CURRENT
STUDIO SETUP

DOCUMENTS

MIDI Source modules reference the devices in the current Studio 
Setup document. If the device name in a MIDI Source module is ital-
icized, then the Patch document being edited probably references a 
non-current Studio Setup document. You can re-define the module 
by:

• making the old Studio Setup document current, or 
• by selecting a different device for every module that is italicized.

If you want to use the current Patch document with your new cur-
rent Studio Setup document, copy the devices from your original 
Studio Setup document into your current Studio Setup document, or 
just rename the devices in the new Studio Setup to match the old 
ones.
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MIDI DESTINATION MODULE

Figure 19: MIDI Destination Module 

A MIDI Destination module represents the device (or virtual desti-
nation) that is the final recipient of MIDI data. When you first insert 
a MIDI Destination module, a question mark appears. To define a 
MIDI destination:

• Click anywhere to the right of the question mark to open a pop-up 
destination menu. This menu contains all destinations as defined in 
the current Studio Setup document. It also contains any Virtual 
Instruments that are defined in the current Patch document (Virtual 
Instruments are discussed in Chapter 3: Virtual Controllers and Vir-
tual Instruments).

• Choose a device or virtual destination from the pop-up menu to 
define the MIDI Destination module.

You can change the device or virtual destination assigned to a MIDI 
Destination module at any time by clicking the name and choosing a 
new destination from the pop-up menu.

Use the MIDI Destination module’s channel numerical to channelize 
MIDI data. Set it to a value of 1-16 to channelize the incoming MIDI 
data. Set it to dash (“-”) if you do not want to change the incoming 
MIDI channel number. Figure 20 illustrates use of the MIDI channel 
numerical.

Figure 20: Destination Module Channelizing Example

MIDI Destination modules, like MIDI Source modules, reference the 
current Studio Setup document. If device names are italicized, the 
MIDI Destination module probably references a non-current Studio 
Setup document. See Referencing Non-Current Studio Setup Docu-
ments, pg. 17 for more details.

Ch 5

Ch 5 input gets changed to Ch 8.
The ProMaker/1 plays the voice 
assigned to MIDI Ch 8.

Ch 5

Ch 5 input does not get changed.
The ProMaker/1 plays the voice 
assigned to MIDI Ch 5.
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EVENT TYPE FILTER MODULE

Figure 21: Event Type Filter Module

An Event Type Filter module removes various types of MIDI events 
from the data stream. Double-click its icon after inserting it into the 
connection. You’ll see a dialog box similar to the one shown in 
Figure 22.

Figure 22: Event Type Filter Edit Window

The three radio buttons control whether the filter will Pass All 
events (useful for temporarily disabling the filter), Pass Only certain 
types of events, or Pass All Except certain events.

Checked boxes remove those event types when Pass All Except is 
chosen. Checked boxes pass those event types through the filter 
when Pass Only is chosen.

In Figure 23, only notes are passed through the Event Type Filter 
module. All other MIDI events are filtered out.

Figure 23: Passing Only Notes Through Filter

You can filter up to seven MIDI continuous controls; choose them 
from the pop-up menus next to the rightmost column of check boxes.
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Most message types are self-explanatory. “Beat Clock” includes 
Song Position Pointer, Song Select, Timing Clock, Start, Stop, and 
Continue messages. “Misc. System” includes Tune Request, System 
Reset, and undefined MIDI status bytes 0xF4, 0xF5, 0xF9, and 0xFD.

? TIP: The Event Type Filter module is useful for “thinning” the MIDI 
data stream prior to sending it to a Splitter module (discussed in the 
following section). A Splitter module can and often does increase the 
amount of MIDI data, so it’s desirable to remove unwanted data 
before it’s duplicated by a Splitter module.

? NOTE: DTL, DTLe, Full Messages and User Bits messages will not 
pass properly through an Event Type Filter unless System Exclusive 
events are allowed to pass. Also, DTL and DTLe will not pass 
through unless clock is also passed.

EVENT TYPE
FILTER MODULE

EXAMPLE

Assume that you want your K2000 keyboard to play the Morpheus, 
but that you don’t want the Morpheus to respond to polyphonic 
aftertouch data.

a Choose Patch>New Patch.

b Double-click the new patch’s selector dot to open a blank Patch Edit Window.

c Click the MIDI Source module, then move the cursor into the patch editing area 
and click. You will create an undefined connection.

d Choose the K2000 from the pop-up MIDI source menu and the Morpheus from the 
pop-up MIDI destination menu (these synthesizers may not be in your Studio 
Setup document, but are presented here as an example).

e Click the Event Type Filter module, and move the cursor between the Source and 
Destination modules. The area becomes highlighted.

f Click the mouse to insert the Event Type Filter module.

g Double-click the Event Type Filter module to open its edit window.
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h Choose Pass All Except and check the Poly Aftertouch box to pass all MIDI 
events except polyphonic aftertouch through to the Morpheus sound module. 

Figure 24: Filtering Poly Aftertouch

i Choose File>Save.

In the future, when you need to play the Morpheus with polyphonic 
aftertouch data filtered out, you can select this patch.

SPLITTER MODULES

Figure 25: Splitter Module Group

A Splitter module takes a single MIDI source and sends it to multiple 
destinations. There are four kinds of Splitter modules:

• Simple
• Channel
• Note Range
• Velocity

If any Splitter module routes two or more of its outputs to the same 
channel of the same device, Studio Patches ensures that the destina-
tion device and channel do not receive duplicate MIDI data. If, 
however, you modify one of the splitter output’s MIDI data streams, 
then the destination device and channel receives both the original 
MIDI stream and the modified events generated by the second MIDI 
stream from the splitter.

For example, if you simply split a MIDI data stream into two sepa-
rate streams then route both streams to the same device and channel, 
Studio Patches ensures that only one stream reaches the destination. 
But, if you modify one of the streams (such as transposing a stream 
up an octave) before routing both streams to the same device and 
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channel, Studio Patches allows both MIDI data streams to reach their 
destination since they are no longer identical. In this example, notes 
and polyphonic aftertouch events are both affected by transposition 
and are both sent to the destination; other events (such as sustain 
pedal or pitch bend) are sent to the destination only once.

If, for any reason, you wish to send duplicate MIDI events to the 
same channel of the same device, split the controller into two Virtual 
Controllers and route them separately. Virtual Controllers are dis-
cussed in Chapter 3: Virtual Controllers and Virtual Instruments.

This discussion on Splitter modules will first cover common Splitter 
editing techniques and then describe each of the four Splitter mod-
ules in detail.

ADDING OUTPUTS
TO A SPLITTER

MODULE

When you first insert a Splitter module into a connection, it doesn’t 
perform as a splitter since it has only one output. However, you may 
still use it to limit the range of notes, velocities or channels sent to a 
single device.

Figure 26: Note Range Splitter With One Output

To create a second output from the Splitter module:

a Click any module icon in the palette (except the MIDI Source module icon).

b Position the cursor below the Splitter module to highlight the area.

Figure 27: Adding Additional Splitter Outputs

c Click the mouse and the connection appears as shown in Figure 28.

Figure 28: Splitter With Two Outputs

d Choose a device for the second destination module.

You can add as many outputs as necessary underneath the splitter 
using the same techniques.
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EDITING SPLITTER
MODULES

You can edit Channel, Note Range, and Velocity Splitter modules. 
You cannot edit Simple Splitter modules.

a Double-click anywhere within an editable Splitter module to open its editing 
window.

Splitter module editing windows contain one line for each output of the splitter. In 
Figure 29, the top keyboard edits the note range of the ProMaker/1 (the top MIDI 
Destination module) and the bottom keyboard edits the note range of the Vectorific 
(the bottom MIDI Destination module).

Figure 29: Note Range Splitter Module

b Move the cursor over an editing line to highlight that splitter output in the 
connection.

Notice, in Figure 30, that the top splitter output is highlighted when the cursor is 
over the top editing line, and that the bottom splitter output is highlighted when the 
cursor is over the bottom line. This makes it easy, when an input is split into many 
outputs, to keep track of which splitter output you are editing.

Figure 30: Highlighting a Splitter Segment

? NOTE: A splitter module must have something connected to its 
output in order to be edited.

EDITING NOTE
RANGE AND

VELOCITY
SPLITTERS WITH

MIDI

You can use a MIDI controller to set note numbers in a Note Range 
Splitter module or to set velocity levels in a Velocity Splitter module.
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Assume, for example, that your Studio Setup document looks like 
the one shown in Figure 31, and that you want to edit Note Range 
Splitter modules and Velocity Splitter modules using either your 
K2000 keyboard or your Octapad.

Figure 31: Sample Studio Setup Document

a In the Studio Patches Editor, choose Windows>Controllers for MIDI Editing to 
open a dialog containing a list of all devices defined in your current Studio Setup 
document.

Figure 32: MIDI Entry Controller Selection Window

b Select the K2000 and Octapad by clicking them. Checked devices are enabled for 
MIDI entry of notes and velocities. Unchecked devices are not enabled.

Figure 33: Selecting Controllers for MIDI Entry of Notes and Velocities
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You can now use either the K2000 or Octapad to enter note and 
velocity data into patch editing modules. Simply highlight a note or 
velocity numerical and hit a note on either controller—this will set 
the numerical to the MIDI value generated by the master controller.

GANG EDITING
NOTE RANGE AND

VELOCITY
SPLITTERS

In both the Note Range and Velocity splitter modules, you can edit 
multiple outputs simultaneously by holding down the shift key 
while you make changes to one of the outputs. This is called “gang 
editing.” Gang editing affects those outputs that are either equal to 
or within a value of “1” from the edited output. This makes gang 
editing particularly useful for editing one splitter output’s high limit 
by the same amount as the other output’s low limit.

Suppose, for example, that you have designed the patch shown in 
Figure 34, but that the velocity split point (set at 63/64) is too low. 
You want to raise the split point to 85/86.

Figure 34: Velocity Split Patch

Shift-click the top output’s Hi velocity value and drag the mouse up 
until the numerical is set for 85. The bottom output’s Lo velocity 
value changes automatically to a value of 86.

Figure 35: Gang Editing Velocity Split Points

SIMPLE SPLITTER
MODULE

Figure 36: Simple Splitter Module

A Simple Splitter module sends one MIDI source to multiple desti-
nations. A Simple Splitter module has no edit window.
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CHANNEL
SPLITTER MODULE

Figure 37: Channel Splitter Module

The Channel Splitter module splits the MIDI data by channel and, if 
desired, changes each output’s MIDI channel. To open an edit win-
dow, insert a Channel Splitter module into a connection, then 
double-click the module.

Figure 38: Channel Splitter Edit Window

Each row in the window controls which channels in the MIDI data 
stream are passed through to the corresponding splitter output. A 
checked channel passes data, an unchecked channel does not. Sys 
includes all MIDI System messages—system exclusive, MIDI Time 
Code, song select, tune request, clock, and system reset. The Chan-
nelize To numerical lets you change all the events passed to an 
output to the same MIDI channel. The “–” character means that the 
data is passed through without having its channel changed.

Read through the following examples to gain a better understanding 
of the Channel Splitter module.

CHANNEL SPLITTER MODULE EXAMPLES

Follow the signal path through these next two connections to under-
stand Channel Splitter modules and channelizing.

Example 1: Look at Figure 39. Notice that the top of the Channel 
Splitter receives data on MIDI Channel 1. It is not channelized, so it 
exits the Splitter module on MIDI Channel 1. The top MIDI Destina-
tion module channelizes the MIDI data from Channel 1 to Channel 4. 
This means that the Morpheus plays the voice assigned to MIDI 
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Channel 4. The bottom half of the Channel Splitter module receives 
data on MIDI Channel 2 and channelizes it to MIDI Channel 3. The 
DR--660 MIDI Destination module is set to Channel “-”, meaning 
that data received at its input is not channelized. Therefore, the 
DR-660 plays the voice assigned to MIDI Channel 3.

Figure 39: First Channel Splitter Example

Example 2: Look at Figure 40. The top half of the connection hasn’t 
changed, but the bottom half is different. Notice that data is still 
received by the Channel Splitter module on Channel 2, channelized 
to MIDI Channel 3, and sent out the Splitter module. The DR-660 
MIDI Destination module is now set to MIDI Channel 1. This means 
that data entering the MIDI Destination module is channelized again 
to MIDI Channel 1, and that the DR-660 plays the voice assigned to 
MIDI Channel 1.

Figure 40: Second Channel Splitter Example

NOTE RANGE
SPLITTER MODULE

Figure 41: Note Range Splitter Module

The Note Range Splitter module limits the range of MIDI notes (and 
polyphonic aftertouch events) routed to each output of the splitter. 
To open its edit window, insert a Note Range Splitter module into a 
connection, then double-click the module.

Figure 42: Note Range Splitter Edit Window
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The edit window contains one line for each of the Splitter’s outputs. 
You can edit each output’s note range with the numericals, the 
graphic keyboard, or MIDI entry. When you click the lower half of 
the keyboard, all notes below the click point disappear, and the 
numericals indicate the new note range. Similarly, clicking high on 
the keyboard removes notes above the click point. Clicking and 
dragging changes the note range as you move the mouse back and 
forth across the keyboard. You can change split points by “gang edit-
ing” as discussed earlier.

MIDI events other than notes and polyphonic aftertouch pass 
through to all outputs of the splitter.

NOTE RANGE SPLITTER MODULE EXAMPLE

Assume, for example, that you want to split your K2000 keyboard to 
produce a right-hand melody sound on Channel 1 of the Morpheus 
and a left-hand bass sound on Channel 1 of the DX7 II.

a Create a new patch and define your Source and Destination modules as discussed 
previously.

b Add a Note Range Splitter module between the MIDI Source and MIDI Destination 
modules.

c Click the MIDI Destination module icon and move the cursor below the Note 
Range Splitter module. The area below the Splitter module becomes highlighted. 

d Click the mouse to add a new, undefined MIDI Destination module.

e Select DX7 II from the MIDI Destination module’s pop-up device menu.

f Select MIDI Channel 1 in the MIDI Destination module’s Channel numerical.
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g Double-click the Note Range Splitter module and enter note ranges for each 
Splitter module output.

As shown here, all notes from C#4 to G9 will be played by the upper MIDI Destina-
tion module (the Morpheus) and all notes from C-1 to C4 will be played by the 
bottom MIDI Destination module (the DX7 II).

VELOCITY
SPLITTER MODULE

Figure 43: Velocity Splitter Module

The Velocity Splitter module allows notes with only specific ranges 
of note-on key velocities to pass through to each output of the Split-
ter module. To open an editing window, insert a Velocity Splitter 
module into a connection, then double-click the module.

Figure 44: Velocity Splitter Edit Window

Like the Channel and Note Range Splitter modules, each row corre-
sponds to one output of the splitter. You can enter velocity values 
with either numerical or MIDI input. You can “gang edit” multiple 
velocity values as discussed previously. Only notes with velocities 
within the specified range will pass through to the Splitter module’s 
output.

MIDI events other than notes are passed through to all outputs of the 
splitter.

? NOTE: Some notes may be cut off early when transposing the out-
puts of a velocity splitter and playing chords.
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TRANSPOSER MODULE

Figure 45: Transposer Module

Use the Transposer module to transpose note and polyphonic after-
touch events. You can edit the Transposer module with either a 
simple edit window or a map edit window.

OPENING AND
USING A SIMPLE

TRANSPOSER EDIT
WINDOW

To open a simple Transposer edit window:

a Insert a Transposer module into a connection.

b Double-click the module.

A simple Transposer edit window opens as shown in Figure 46.

Figure 46: Simple Transposer Edit Window

The transposition interval is expressed musically, not as a number of 
half-steps. If you prefer thinking in terms of half-steps, type the 
number of half steps into the numerical, then hit the Return or Enter 
keys. Negative values transpose downward and positive values 
transpose upward. The Transposer module in Figure 46 transposes 
the MIDI note values up 1 octave plus a Major 2nd (14 half-steps).

Figure 47 shows the relationship between intervals and half-step 
values.

Figure 47: Relation of Intervals to Half-Steps

m2
M2
m3
M3
P4
#4
P5
m6
M6
m7
M7
+1 oct

minor second
major second
minor third
major third
perfect fourth
sharp fourth (tritone)
perfect fifth
minor sixth
major sixth
minor seventh
major seventh
up one octave

1 half-step
2 half-steps
3 half-steps
4 half-steps
5 half-steps
6 half-steps
7 half-steps
8 half-steps
9 half-seps
10 half-steps
11 half steps
12 half steps
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? NOTE: Transposer modules change MIDI note numbers. They do 
not actually alter the internal tuning of your synthesizers. The musi-
cal intervals expressed in the Transposer module are based on 
standard Equal Temperament. Actual tuning amounts will change if 
you use alternate synthesizer tuning scales.

OPENING AND
USING A MAP

TRANSPOSER EDIT
WINDOW

To open a map Transposer edit window:

a Click the Map button in the simple Transposer edit window.

A map Transposer edit window opens to show the current conditions of the simple 
Transposer (as seen in Figure 48).

Figure 48: Opening the Map Transposer Edit Window

The scrolling keyboard along the right edge of the window lets you 
map any MIDI note to any other MIDI note. Use the To numerical to 
transpose each individual note (you can set each numerical using 
MIDI entry, see Module Editing Basics, pg. 16).

The controls in the left half of the window allow you to duplicate the 
transpositions defined in one note range for any other note range. 
For example, the default setting lets you create a transposition map 
for the twelve notes of one octave, then duplicate these transposi-
tions for all octaves. Use the four numericals to set the two ranges, 
then click the Extend button to perform the extension.

? NOTE: You may want to define some commonly used transposition 
maps as either Virtual Controllers or Virtual Instruments and use 
them instead of a map in your Studio Patches. Virtual Controllers 
and Virtual Instruments are discussed in Chapter 3: Virtual Control-
lers and Virtual Instruments.

? Maps use a relatively large amount of memory, so if you find yourself 
using the same map in multiple places in the same Patch document, 
you’ll use less memory by putting maps into Virtual Controllers or Vir-
tual Instruments.

This Simple

...opens this Map

Map
 

 Transposer edit
window setting

Transposer Edit
Window when you
click the 
button.
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CHOOSING
BETWEEN A

SIMPLE OR MAP
TRANSPOSITION

If you click the map edit window’s close box, the map edit window 
closes and the Transposer module will use that map to transpose 
MIDI data. The map edit window opens the next time you double-
click that Transposer module.

If you click the No Map button, you’ll delete your custom map, close 
the map edit window, and re-open the simple edit window. The 
Transposer module will use the settings in the simple edit window 
to transpose MIDI data.

MODIFIER MODULES

Figure 49: Modifier Module Group

Use Modifier modules to alter note-on velocities, mono aftertouch, 
poly aftertouch, pitch bend and MIDI control values. Each Modifier 
module uses either a simple Modifier edit window or a map Modi-
fier edit window to modify MIDI data.

OPENING AND
USING A SIMPLE

MODIFIER EDIT
WINDOW

To open a simple Modifier edit window:

a Insert a Modifier module into a connection.

b Double-click the new module.

A simple Modifier edit window opens as shown in Figure 50.

Figure 50: Typical Simple Modifier Edit Window

Each Modifier module’s simple edit window contains a pop-up 
menu of modifiers. The choices are Add, Scale, Invert, Max Limit, 
Min Limit, Set To, and Filter Out. The modification amount is set by 
the numerical to the right.

• Add: Adds the specified number to each MIDI data value. Positive 
and negative values may be used.

• Scale: Scales the value by the specified percentage: 100% is 
unchanged, 50% halves each value, 199% (the maximum) nearly 
doubles each value (you cannot have values greater than 127 or less 
than 0, however).
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• Invert: Changes 127->0, 126->1, 125->2, 1->126, and 0->127 except in 
the case of velocity where 0 (a note off) is left unchanged.

• Max Limit: Reduces all values higher than the specified value down 
to the limit you enter. 

• Min Limit: Increases all values lower than the specified value up to 
the limit you enter.

• Set To: Changes all values to the one you enter.
• Filter Out: Removes the event type completely (not allowed for 

velocity).

OPENING AND
USING A MAP

MODIFIER EDIT
WINDOW

To open a Modifier module’s map edit window, click the Map 
button in the Simple Modifier edit window. A map Modifier edit 
window opens to show the current conditions of the Simple Modifier 
(as seen in Figure 51).

Figure 51: Opening a Map Modifier Edit Window

Click and drag inside the mapping area to create a new modifier 
map. The current cursor location’s input value is shown below the 
map and its re-mapped value is shown to the left. MIDI data enter-
ing the Modifier module gets modified according to the curve.

Figure 52 illustrates a simple S-curve map—low and high input 
values result in very little output change, but middle input values 
create great changes in output values. Notice, as an example, that a 
value of 76 entering the Modifier module gets remapped to 95 before 
leaving the module.

This Simple 
Modifier edit 
window setting...

...opens this Map 
Modifier edit 
window when you 
click the Map 
button.



Ch 2: Patch Modules - 34 - Studio Patches Manual

Figure 52: Simple S-Curve Modifier Map

To draw a straight line between two points, click at one end point, 
then shift-click at the other end point (see Figure 53).

Figure 53: Drawing Straight Lines

? NOTE: You may want to define some commonly used transposition 
maps as either Virtual Controllers or Virtual Instruments and use 
them instead of a map in your Studio Patches. Virtual Controllers 
and Virtual Instruments are discussed in Chapter 3: Virtual Control-
lers and Virtual Instruments.

? Maps use a relatively large amount of memory, so if you find yourself 
using the same map in multiple places in the same Patch document, 
you’ll use less memory by putting maps into Virtual Controllers or Vir-
tual Instruments.

(a) (b)

(c)

a) Click a beginning point.
b) Shift-click an endpoint..
c) A straight line is drawn 
between the two points.
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CHOOSING
BETWEEN SIMPLE

AND MAP
MODIFIERS

If you click the map edit window’s close box, the map edit window 
closes and the Modifier module will use that map to modify MIDI 
data. The map edit window opens the next time you double-click 
that Modifier module.

If you click the No Map button, you’ll delete your custom curve, 
close the map edit window, and re-open the simple edit window. 
The Modifier module will use the simple edit window settings to 
modify MIDI data.

VELOCITY
MODIFIER

Double-click the Velocity Modifier module to open its edit window. 
You can modify velocity values using either the simple or map edit 
windows. You cannot filter out velocity data, nor can you invert a 
note-off value of 0 (zero).

AFTERTOUCH
MODIFIER

Double-click the Aftertouch Modifier module to open its edit win-
dow. You can modify mono aftertouch values using either the 
simple or map edit windows.

POLY
AFTERTOUCH

MODIFIER

Double-click the Polyphonic Aftertouch Modifier module to open its 
edit window. You can modify poly aftertouch values using either the 
simple or map edit windows.

PITCH BEND
MODIFIER

Double-click the Pitch Bend Modifier module to open its edit win-
dow. You can modify pitch bend values using either the simple or 
map edit windows.
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CONTROL VALUE
MODIFIER

Double-click the Control Value Modifier to open its edit window. 
This window contains an additional pop-up menu for choosing 
which MIDI continuous control value to modify.

Figure 54: Control Value Modifier Edit Window

The Control Value Modifier module contains a small number in its 
lower right corner. This indicates the number of the control being 
modified. 

Figure 55: Control Number Indicator

CONTROL NUMBER MAPPER MODULE

The Control Number Mapper module changes one type of MIDI con-
trol message into another. To open an edit window for the Control 
Number Mapper module, insert it into a connection, then double-
click the module.

Figure 56: Control Number Mapper Edit Window

The Control Number Mapper module’s edit window contains two 
pop-up menus. Choose the old control number from the top pop-up 
menu. Use the bottom pop-up menu to choose the new control 
number.
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CONTROL
NUMBER MAPPER

MODULE EXAMPLE

Assume, for example, that you wanted to play your Morpheus from 
your K2000 keyboard, and that you wanted to control the Morpheus’ 
volume with the K2000 modulation wheel.

a Create a connection with the K2000 as the MIDI source and the Morpheus as the 
MIDI destination.

b Insert the Control Number Mapper module into the connection, then double-click it 
to open its edit window.

c Choose Mod Wheel (1) from the upper pop-up menu.

d Choose Volume (7) from the lower pop-up menu.

Figure 57: Mapping Mod Wheel to Volume

The K2000 modulation wheel now controls the Morpheus output 
volume.



Ch 3: Virtual Controllers and Virtual Instruments - 38 - Studio Patches Manual

CH 3: VIRTUAL CONTROLLERS AND 
VIRTUAL INSTRUMENTS

Virtual Controllers and Virtual Instruments are extremely powerful 
features of Studio Patches. Basically, they’re enhanced versions of 
the MIDI devices defined in your current Studio Setup document. 
Any number of Virtual Controllers and Virtual Instruments can be 
stored within a Patch document.

A Virtual Controller is the output of a MIDI device plus some form 
of MIDI processing. A Virtual Controller is treated the same as any 
other MIDI controller defined in your current Studio Setup docu-
ment, except that it enhances the performance of a MIDI controller 
by adding MIDI processing. Virtual Controllers have two important 
uses:

• They are used when common MIDI processing connections need to 
be used in multiple Studio Patches.

• They are used as sequencer inputs when you need to record a MIDI 
controller with some processing applied.

Basically, Virtual Controllers are additional sources of MIDI data 
(just like real MIDI controllers). You create these new sources by 
combining your real MIDI controllers with MIDI processing.

A Virtual Instrument is some form of MIDI processing routed to one 
or more MIDI devices. A Virtual Instrument is treated the same as 
any other MIDI destination defined in your current Studio Setup 
document, except that it enhances performance by stacking, splitting 
or layering various devices and adding MIDI processing. Virtual 
Instruments have two important uses:

• They are used when common MIDI processing connections need to 
be used in multiple Studio Patches.

• They are used as sequencer destination instruments—allowing the 
sequenced tracks to play into a MIDI processed stream.

Basically, Virtual Instruments are additional destinations of MIDI 
data (just like real MIDI sound modules). You create these new desti-
nations by combining your real MIDI sound modules with MIDI 
processing.
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? NOTE: MIDI data can sometimes get very dense when working with 
Virtual Controllers and Virtual Instruments. Therefore, when design-
ing your patches, it’s a good idea to use Event Type Filter Modules to 
remove any unnecessary data.

The following sections discuss Virtual Instruments and Virtual Con-
trollers: why you may wish to use them, how to set them up, and 
how to access them within Opcode’s Vision and Studio Vision.

USING VIRTUAL CONTROLLERS

A Virtual Controller is the output of a MIDI device plus some form of 
MIDI processing. Let’s look at an example of a Virtual Controller.

Assume that your keyboard is too sensitive to aftertouch. Pushing 
just slightly on the keys causes it to send very high aftertouch values. 
You can design a Virtual Controller that processes the aftertouch 
data before sending it to your sequencer or MIDI devices.

a Click the Virtual Controllers button or choose Patch>Edit Virtual Controllers to 
open a Virtual Controllers Edit Window.

Figure 58: Virtual Controllers button

You’ll see that the Virtual Controllers Edit Window looks very similar to the Patch 
Edit Window. Use the Virtual Controllers Edit Window to create and store as many 
Virtual Controllers as memory will allow.

Figure 59: Virtual Controllers Edit Window

b Click the MIDI Source module icon. The cursor will turn into the MIDI Source icon. 
Click anywhere in the space below the Module Palette to create an undefined 
connection.

Notice that this connection looks very similar to an undefined patch connection; the 
only difference is that the MIDI Destination module is replaced by a Virtual Control-
ler module.

c Choose your master keyboard from the MIDI Source module’s pop-up menu.
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d Insert a Mono Aftertouch Modifier module between the MIDI Source module and 
the Virtual Controller module.

e Double-click the Mono Aftertouch Modifier module to open its editing window.

f Choose Scale from the Modifier module’s pop-up menu and enter a value of 50% 
into the Modifier module’s numerical.

This will scale the Mono Aftertouch output by 50%, resulting in the desired 
decrease in Mono Aftertouch sensitivity.

g Click the Virtual Controller Module. Its border will become thick and it will contain a 
flashing text-insertion cursor.

h Type a suitable name for your new Virtual Controller.

i Close the Virtual Controllers Edit Window.

If you open a patch in the Patch Edit Window, you’ll see that “Master w/A.T. Scal-
ing” has been added to your list of possible MIDI sources. Now, instead of using 
the K2000 as a controller, you can use the improved Virtual Controller as your 
MIDI source.

The previous example provided a graphic illustration of the Virtual 
Controller definition—Virtual Controllers are the output of a MIDI 
device plus some form of MIDI processing.

Virtual Controllers are edited similarly to patches, except that 
instead of MIDI Destination Modules, there are Virtual Controller 
Modules.



Ch 3: Virtual Controllers and Virtual Instruments - 41 - Studio Patches Manual

All of the modules and connections to the left of the Virtual Control-
ler Module are used to define the output of that Virtual Controller. 
There may be any number of Virtual Controllers for each real 
controller.

Virtual Controllers appear in the pop-up MIDI source menus when 
you edit a patch. If you choose a Virtual Controller, it has the same 
appearance in the Patch Edit Window as in the Virtual Controllers 
Edit Window, except that you can’t edit its name.

EFFICIENT USE OF
VIRTUAL

CONTROLLERS

There are two kinds of Virtual Controller connections:

• Those that do not “multiply” MIDI data.
In this type of a connection, no one MIDI event from a source reaches 
more than one Virtual Controller. You make non-multiplying Virtual 
Controller connections either by avoiding multi-output splitter mod-
ules or by extensive use of filtering. An example of two different 
non-multiplying connections is shown in Figure 60.

Figure 60: Non-Multiplying Virtual Controller Connections

• Those that do “multiply” MIDI data.
In this type of connection, a single MIDI event from a source reaches 
more than one Virtual Controller. Connections that use unfiltered, 
multi-output splitter modules multiply MIDI data by sending dupli-
cate data to numerous Virtual Controllers. An example of a 
multiplying connection is shown in Figure 61.

Figure 61: Multiplying Virtual Controller Connection

The connection shown in Figure 61 doubles all MIDI events (pitch 
bend, controls, mono aftertouch, etc.) except for notes and poly-
phonic aftertouch events.
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When you design patches using Virtual Controllers created in a 
“multiplying” connection, avoid using the Virtual Controllers inde-
pendently. Either use all of the Virtual Controllers created in a 
multiplying connection or don't use any at all. If you don't use all of 
a multiple connection's Virtual Controllers, you will waste micropro-
cessor power since you'll send MIDI data to Virtual Controllers that 
aren't in your patch.

For example, if you wanted to create a patch where your left hand 
controls one module and your right hand controls another, you 
could use the two Virtual Controllers shown in Figure 62.

Figure 62: Patch Using Virtual Controllers from Multiplying Connection

If, however, you wanted to create a patch where only your left hand 
controlled a module, you should use the “LH: B3&DOWN” Virtual 
Controller shown in Figure 63.

Figure 63: Patch Using Virtual Controllers from Non-Multiplying Connection

If, instead of using the “LH: B3&DOWN” Virtual Controller in the 
patch, you used the “LH: C4 Split” Virtual Controller shown in 
Figure 62, you would waste processing power since all MIDI events 
generated by the K2000 (other than notes and poly aftertouch) are 
sent to both the “LH: C4 Split” and “RH: C4 Split” Virtual Control-
lers. Since this patch doesn’t use the “RH: C4 Split” Virtual 
Controller, this would be an inefficient use of Virtual Controllers and 
your interface’s microprocessor.

USING VIRTUAL
CONTROLLERS

WITH VISION

OMS applications such as Vision and Studio Vision (versions 1.3 or 
later) treat Virtual Controllers as they would any other MIDI input 
device.
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Let’s look at an example showing how to use Virtual Controllers 
with Vision. Assume that your Studio Setup document looks like 
Figure 64, and that you have defined a Virtual Controller like the one 
shown in Figure 65.

Figure 64: Studio Setup Document Example

Figure 65: Virtual Controller Example

a Launch Vision.

b Choose Setups>Enable Input Devices.

You’ll see a dialog box listing all possible MIDI input devices, including any Virtual 
Controllers, as defined by the current Studio Patch document.

Figure 66: Vision’s “Enable Input Device” Dialog Box
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Notice, in this example, that the Virtual Controller named “Master 
w/A.T. Scaling” is available as a MIDI input source. You enable 
input devices by clicking them. In the following example, “Master 
w/A.T. Scaling” is checked and, therefore, is enabled as an input 
device.

Figure 67: Enabling a Virtual Controller in Vision

By using the specially designed “Master w/A.T. Scaling” Virtual 
Controller as an input device, you can record data with satisfactory 
aftertouch values directly into Vision.

? NOTE: Since Virtual Controllers use real MIDI input devices, it’s pos-
sible to accidentally enable an input device twice. For example, if you 
enable both “K2000” and “Master w/A./T. Scaling,” you will get two 
notes for every one you play. For this reason, make sure that you 
only enable one input for each real, physical device.

VIRTUAL INSTRUMENTS

A Virtual Instrument is made up of one or more MIDI destinations 
plus some form of MIDI processing. Virtual Instruments are basically 
the opposite of Virtual Controllers. Let’s look at an example of a Vir-
tual Instrument.

Assume that it’s common for you to “stack” instruments together to 
get a really big MIDI sound—particularly your K2000 and Morpheus 
sound modules playing on MIDI Channel 2. Using Virtual Instru-
ments, you can create that stack and always have it available as a 
MIDI destination.

a Click the Virtual Instruments button in the Patch Document Window, or choose 
Patch>Edit Virtual Instruments to open a Virtual Instruments Edit Window.

Figure 68: Virtual Instruments button
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You’ll see that the Virtual Instruments Edit Window looks very similar to the Patch 
Edit Window. Use the Virtual Instruments Edit Window to create and store as many 
Virtual Instruments as memory will allow.

Figure 69: Virtual Instruments Edit Window

b Click the Virtual Instrument module icon.

Figure 70: Virtual Instrument Module Icon

c Click in the blank space below the Module Palette to create an undefined Virtual 
Instrument connection.

Notice that this connection looks very similar to an undefined patch connection; the 
only difference is that the MIDI Source module is replaced by a Virtual Instrument 
module.

d Insert a Simple Splitter module between the Virtual Instrument and the MIDI 
Destination modules.

e Add a second MIDI Destination module by clicking its icon and inserting it below 
the Simple Splitter module.

f Choose the K2000 from the upper MIDI Destination module’s pop-up menu, and 
the Morpheus from the lower MIDI Destination module’s pop-up menu. Set their 
MIDI channels to 2.

g Click the Virtual Instrument module to select it.
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h Type in the name of your new Virtual Instrument and hit the Enter key.

i Close the Virtual Instruments Edit Window.

If you open a patch in the Patch Edit Window, you’ll see that “Hip-
poStack” has been added to your list of MIDI destinations. 
Whenever you want to play a stack made up of the K2000 and Mor-
pheus synthesizers on MIDI Channel 2, simply choose this Virtual 
Instrument as the MIDI destination.

The previous example provided a graphic illustration of the Virtual 
Instrument definition—Virtual Instruments are made up of one or 
more MIDI destinations plus some form of MIDI processing.

Like Virtual Controllers, Virtual Instruments are edited similarly to 
patches with only minor exceptions. The Virtual Instruments Edit 
Window contains connections from Virtual Instruments to devices.

Instead of MIDI Source modules, there are Virtual Instrument 
modules:

Virtual Instruments appear in the pop-up MIDI destination menus 
when you edit a patch. If you choose a Virtual Instrument, it has the 
same appearance in the Patch Edit Window as in the Virtual Instru-
ments Edit Window, except that you can’t edit its name.

? NOTE: System Exclusive messages should always be sent directly 
to the intended device. Sending System Exclusive to a Virtual Instru-
ment containing a Splitter module and different devices thickens the 
MIDI data stream unnecessarily. Sending System Exclusive to a Vir-
tual Instrument consisting of a Splitter module routed to different 
channels of the same device may corrupt the data.
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USING VIRTUAL
INSTRUMENTS

WITH VISION

OMS applications such as Vision and Studio Vision (versions 1.3 or 
later) treat Virtual Instruments as they would any other MIDI desti-
nation device.

Let’s look at an example showing how to use Virtual Instruments 
with Vision. Assume that your Studio Setup document looks like 
Figure 71, and that you have defined a Virtual Controller like the one 
shown in Figure 72.

Figure 71: Studio Setup Document Example

Figure 72: Virtual Instrument Example

a Launch Vision.

b Choose Windows>Instruments.

c Choose New Instrument from the Instruments menu.

A new Instrument will be added to the MIDI Instruments list as shown in Figure 73.

Figure 73: Adding an Instrument in Vision

d Choose “HippoStack” from the MIDI Output Device pop-up menu.

This menu displays all MIDI destinations as defined in your current Studio Setup 
document as well as the Virtual Instruments in your current Studio Patch 
document.

Figure 74: Selecting a MIDI Output Device in Vision
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e Choose Channel 2 from the MIDI Output Channel pop-up menu (since 
“HippoStack” was designed to play on MIDI Channel 2).

The MIDI Instrument’s name becomes “HippoStack-2,” indicating that it uses the 
Virtual Instrument named “HippoStack,” and that it is set to receive on MIDI Chan-
nel 2. You can keep this name or type another.

Figure 75: Newly Defined Instrument in Vision

f Click on the Thru Instrument setting at the left side of Vision’s Control Bar (the little 
keyboard).

You’ll see a pop-up menu of MIDI Instruments as defined in Vision’s Instruments 
Window.

Figure 76: Choosing a Virtual Instrument in Vision

g Choose “HippoStack-2.”

The Thru Instrument will now play the Virtual Instrument named 
“HippoStack,” which is the combined sound of the K2000 and Mor-
pheus sound modules on MIDI Channel 2.

Virtual Instruments can be used to define any number of MIDI 
Instruments within Vision. You can choose instruments within any 
of Vision’s MIDI Instrument pop-up menus (as found in the Tracks 
Window, List Window, Graphic Window, and so on).There are two 
important advantages to using Virtual Instruments with Vision:

• You wish to play a sequence using an interesting Studio Patch.
To do so, simply create a Virtual Instrument consisting of the entire 
patch connection (except for the source module) and use it as 
Vision’s Thru Instrument. This is detailed in the following section.
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• You wish to have a sound made up of several channels on several 
devices playing the same part.
(This applies to Studio 5’s only.) Without Virtual Instruments, you 
would have the Macintosh send a separate MIDI event to each desti-
nation channel on each device. Using a Virtual Instrument allows the 
Macintosh to send just one MIDI event to the Virtual Instrument, 
which actually exists inside the interface. This reduces the density of 
the MIDI data stream, making timing more efficient.
It also transfers the Macintosh’s work load to the interface, which 
gives the Macintosh more processing time for other events.

CREATING
VIRTUAL

INSTRUMENTS
FROM EXISTING

PATCHES

If you create an interesting Studio Patch and decide you want to use 
it as a Virtual Instrument in a MIDI sequence, you can simply copy 
the connection (less the MIDI Source module) from the Patch Edit 
Window and paste it into the Virtual Instruments Edit Window. To 
do so:

a Open the Patch Edit Window for the patch you want to turn into a Virtual 
Instrument.

b Select every part of the connection except the MIDI Source module.

There are two ways to do this: 1) click the selector dot to the left of the connection 
(selecting all modules), then option-click the MIDI Source module to deselect it; or 
2) drag a rectangle around all the modules except the MIDI Source module.

c Choose Edit>Copy.

d Open the Virtual Instruments Edit Window.

e Click the Virtual Instrument module icon, then click in the blank space below the 
Module Palette to create an undefined Virtual Instrument connection.

f In the new connection, click the MIDI Destination module to select it and hit the 
Delete key to remove the MIDI Destination module from the connection.
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g Click the MIDI Destination module icon, then move the cursor just to the right of the 
Virtual Instrument module. Do not click the mouse!

Notice that the area to the right of the Virtual Instrument module becomes 
highlighted.

h Choose Edit>Paste to paste the contents of the clipboard into the highlighted 
area.

i Type a name into the Virtual Instrument module and save it.

You’re now ready to use this newly created virtual instrument in your sequencing 
program.

Highlighting
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CH 4: PROGRAM CHANGE 
SOURCES

Use the Program Change Sources Window to specify various ways 
to change Studio Patches. You can design Program Change Sources 
to:

• Change Studio Patches from a MIDI controller.
• Change Studio Patches from a MIDI controller only if an additional 

MIDI control is activated.
• Step through a pre-determined Patch Chain using a MIDI controller.

Program Change Sources make it convenient to change Studio 
Patches from a MIDI controller when you’re working within other 
MIDI applications. You don’t have to use the Patch Document 
Window to change Studio Patches. A Patch document can contain 
any number of Program Change Sources.

OPENING A PROGRAM CHANGE SOURCES EDIT WINDOW

Click the Program Change Sources button in the Patch Document 
Window, or choose Patch>Edit Program Change Sources to open 
the Program Change Sources Window.

Figure 77: Program Change Sources button

You’ll see that the Program Change Sources Window looks similar to 
the Patch Edit Window, except that the module palette is different.

Figure 78: Empty Program Change Sources Window
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PROGRAM CHANGE SOURCES EDIT WINDOW TERMINOLOGY

Figure 79 shows the terminology for the Program Change Sources 
Window.

Figure 79: Anatomy of a Program Change Sources Window

Module placement and editing techniques are similar to those used 
for the Patch Edit Window. The following sections discuss each 
module in detail.

MIDI SOURCE MODULE

Figure 80: MIDI Source Module

The MIDI Source module in the Program Change Sources Window is 
very similar to the MIDI Source module in the Patch Edit Window. 
The only difference is that this MIDI Source module contains a MIDI 
channel numerical; the Patch Edit Window’s MIDI Source module 
does not.

Use this MIDI Source module to specify which device and MIDI 
channel will control program changes using the other modules to 
which it's connected.

To insert and define a MIDI Source module:

a Click the MIDI Source module icon. The cursor will change into a MIDI Source 
module icon.

b Click in the blank space below the Module Palette to create an undefined Program 
Change connection.

MIDI Source 
Module icon

Change Patches 
Module icon Enable Patch 

Changes Module icon

Patch Chain Controls 
Module icon

Module 
Palette

Program Change Source

ModulesEditing Area

(You can have as many
Program Change Sources
as you need)
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c Choose a MIDI source from the MIDI Source module’s pop-up menu.

d Use the Channel numerical to set a MIDI transmission channel. A dash (“-”) means 
that the MIDI source data can come from any channel.

You will not yet be able to change Studio Patches via MIDI, since the 
MIDI Source module’s only purpose is to define the source and 
channel of MIDI data. See the following sections to learn how to 
change Studio Patches using several different methods.

CHANGE STUDIO PATCHES

Figure 81: Change Studio Patches Module

If you want Studio Patches to receive MIDI program changes from a 
MIDI device, you must use the Change Studio Patches module (to 
change Studio Patches using MIDI program changes sent from an 
OMS application, send to the “Studio Patches pgm chg” device, 
described in Sequencing Patch Changes, pg. 9).

Place a Change Studio Patches module to the right of the MIDI 
Source module using techniques discussed previously.

Figure 82: Adding a Change Studio Patches Module

In the example shown in Figure 82, MIDI program changes transmit-
ted by the K2000 on Channel 1 will change the Studio Patch number.

EDITING THE
CHANGE STUDIO

PATCHES MODULE

Double-click the Change Studio Patches module to open its edit 
window.

Figure 83: Change Studio Patches Module Edit Window
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The edit window contains a single check box. When the box is 
unchecked, Studio Patches recognizes MIDI program changes 
directly. When the box is checked, the status of an additional MIDI 
controller (typically a footswitch or button) determines whether 
Studio Patches recognizes the program change message.

Uncheck the box if you want Studio Patches to always change 
patches when it receives a MIDI program change message. Often, 
however, it’s undesirable to change the Studio Patch every time you 
send program changes from your master keyboard. If you check the 
check box, Studio Patches change only when an additional MIDI con-
trol event is received. This allows you to send program changes to 
MIDI devices without changing the Studio Patch.

If you check the check box, you’ll need to use an Enable Studio Patch 
Changes module (see the following section).

ENABLE STUDIO PATCH CHANGES MODULE

Figure 84: Enable Studio Patch Changes Module

If you checked the check box in the Change Studio Patches module 
edit window, you must use the Enable Studio Patch Changes 
module to change Studio Patches.

a Add a new MIDI Source module to the Program Change Sources Window.

Figure 85: Adding a Second Connection

b Choose a MIDI Source and channel, then place an Enable Studio Patch Changes 
module to the right of the MIDI Source module.

Figure 86: Defining Studio Patch Change Enabling Source
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EDITING THE
ENABLE STUDIO

PATCH CHANGES
MODULE

Double-click the Enable Studio Patch Changes module to open its 
edit window.

Figure 87: Enable Studio Patch Changes Module Edit Window

Use the pop-up menu to specify which MIDI control message 
enables Studio Patches program changes. You can choose whether 
the control message needs to be “on” or “off” in order to enable pro-
gram changes.

In the connection shown in Figure 88, the Masterman-88 will change 
Studio Patches only if you send the program change while holding 
down the Studio 5’s Footswitch #1. Program Change messages from 
the Masterman-88 will not affect Studio Patch selection if the 
Studio 5 footswitch is not down (on).

Figure 88: Example of an Studio Patch Change Connection

? NOTE: Remember that Studio 5 footswitch and foot controller data is 
sent on MIDI Channel 15.
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USING A SINGLE
STUDIO PATCH

CHANGE AND
ENABLE SOURCE

If you wish to use a single MIDI source for both Studio Patch 
changes and enabling, you’ll use only one connection.

Assume, for example, that you wanted to send Studio Patch changes 
from your Masterman-88 controller while holding down its sustain 
pedal. You would create the connection shown in Figure 89.

Figure 89: Single Studio Patch Change and Enable Source

PATCH CHAIN CONTROLS MODULE

Figure 90: Patch Chain Controls Module

Use this module to select a pair of MIDI controls to step up or down 
through a pre-defined Patch Chain. You define the Patch Chain in 
the Patch Chain Edit Window (see Chapter 5: Patch Chains).

Place a Patch Chain Controls module to the right of a MIDI Source 
module using techniques discussed previously.

Figure 91: Adding a Patch Chain Controls Module
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EDITING THE
PATCH CHAIN

CONTROLS
MODULE

a Double-click the Patch Chain Controls module to open its edit window.

Figure 92: Patch Chain Controls Module Edit Window

b Choose (from the Forward pop-up menu) the MIDI control you wish to use to step 
forward through the Patch Chain.

c Choose (from the Backward pop-up menu) the MIDI control you wish to use to step 
backward through the Patch Chain.

For the example shown in Figure 92, you would use the Studio 5’s 
Footswitch #1 to step forward through a Patch Chain, and the 
Studio 5’s Footswitch #2 to step backward through a Patch Chain.

Patch Chains wrap around. When you reach the last patch in a chain, 
the next step will return you to the first patch in the chain.

See Chapter 5: Patch Chains to learn how to set up a Patch Chain.

? NETWORKING NOTE: If you’re using multiple interfaces, Opcode 
recommends you connect all MIDI devices defined as Patch Chain 
control sources to the same interface. The reason is that each micro-
processor (whether it’s in the Macintosh or an interface) has its own 
concept of the current location in the Patch Chain. If you use different 
devices connected to different interfaces to advance a Patch Chain, 
you may get unexpected results.
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CH 5: PATCH CHAINS

The Patch Chain Edit Window creates a list of patches used by the 
Patch Chain Controls module (discussed in Chapter 4: Program 
Change Sources). The Patch Chain Controls module (found in the 
Program Change Sources Window) lets you step through a predeter-
mined patch sequence using an external MIDI controller.

This chapter discusses creating and editing a Patch Chain.

OPENING A PATCH CHAIN EDIT WINDOW

Click the Patch Chain button in the Patch Document Window, or 
choose Edit>Patch Chain to open the Patch Chain Edit Window.

Figure 93: Patch Chain Button

Figure 94: Empty Patch Chain Edit Window
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PATCH CHAIN EDIT WINDOW TERMINOLOGY

Figure 95 shows the terminology for the Patch Chain Edit Window.

Figure 95: Anatomy of a Patch Chain Edit Window

A Insert Patch Chain Steps Button
B Patch Document List
C Patch Chain List (each item in the list is called a Step)
D Selector Dot
E Insertion Point

The Patch Chain Edit Window is divided into two scrolling lists. The 
list on the left is a copy of the current Patch document. It lists all the 
current patches and shows the first line of each patch description. 
The list on the right is the Patch Chain.

CREATING A PATCH CHAIN

You create a Patch Chain by defining an insertion point in the Patch 
Chain List and selecting patches from the Patch Document List.

The Patch Chain List is blank when you first open an empty Patch 
Chain Edit Window.

a Click the selector dot of a patch in the Patch Document List. 

Figure 96: Select Patch from Patch Document List

b Click the Insert Patch Chain Steps button to insert the patch in the Patch Chain 
List.

1

2 3

4
5
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Figure 97: Click Patch Chain Steps Button

Notice that the insertion point moves to follow the step just inserted.

? SHORTCUT: Double-click a selector dot in the Patch Document List 
to insert that patch into the Patch Chain List automatically. When you 
double-click a patch selector dot, you do not have to click the Insert 
Patch Chain Steps button to insert the patch.

SELECTING
MULTIPLE
PATCHES

You can insert multiple patches into the Patch Chain List by selecting 
more than one patch at a time from the Patch Document List.

a Shift-click two or more patches in the Patch Document List.

Figure 98: Shift-Clicking Multiple Patches

b Click the Insert Patch Chain Steps button to insert the selected patches at the 
insertion point in the Patch Chain List.

Figure 99: Inserting Multiple Patches

USING THE “ALL
PATCHES IN

ORDER” CHECK
BOX

The All Patches In Order check box, when checked, replaces the cur-
rent Patch Chain with a chain containing all patches in the Patch 
document. Patches appear in numerical order (not necessarily in the 
order they appear in the Patch Document List). If you add, remove, 
or renumber patches in a Patch document when All Patches In 
Order is checked, the Patch Chain will change to always reflect your 
Patch document.
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You may not make changes directly to the Patch Chain List when All 
Patches In Order is checked. If you want to make changes to a Patch 
Chain List, first uncheck All Patches In Order.

Assume, for example, that you had the Patch Chain shown in 
Figure 100.

Figure 100: Patch Chain before Checking All Patches In Order

Click the All Patches In Order check box to check it. Your Patch 
Chain now lists, in numerical order, all the patches in your current 
Patch document (see Figure 101).

Figure 101: Patch Chain after Checking All Patches In Order

EDITING A PATCH CHAIN

You may cut, copy, paste and clear Patch Chain Steps. Cut and 
copied Patch Chain Steps appear in the Clipboard window. The fol-
lowing example shows how to copy and paste a Patch Chain Step.

a Click the selector dot next to the Patch Chain Step you wish to copy.

b Choose Edit>Copy.

Figure 102: Select and Copy a Patch Chain Step
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c Click between Patch Chain Steps to select a new insertion point.

Figure 103: Defining an Insertion Point

d Choose Edit>Paste to paste the copied Patch Chain Step at the insertion point.

Figure 104: Pasting a Patch Chain Step

If you paste a Patch Chain Step without selecting an insertion point, 
it will be inserted at the end of the Patch Chain List. For example:

a Copy a Patch Chain Step to the Clipboard as shown in Figure 105.

Figure 105: Copying a Patch Chain Step

b Paste the Patch Chain Step without choosing an insertion point. Look at 
Figure 106 to see that the Patch Chain Step was pasted to the end of the Patch 
Chain List.

Figure 106: Pasting to the End of the Patch Chain List

? NOTE: If the Insert Patch Chain Steps button is dimmed, it means 
you have not defined an insertion point. If you paste a Patch Chain 
Step without selecting an insertion point, it will appear at the end of 
the Patch Chain List.
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CHANGING THE PATCH DOCUMENT

If the Patch Chain references a patch that you later remove from the 
Patch Document Window, the Patch Chain continues to reference 
the patch by its number.

Follow this example to see how deleting a patch affects the Patch 
Chain:

a Look at the Patch Chain Window shown in Figure 107. Notice the position of 
Patch #8 in both the Patch Document List and the Patch Chain List.

Figure 107: Typical Patch Chain Window

b Open the current Patch Document Window and select Patch #8.

Figure 108: Selecting a Patch in the Patch Document Window
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c Choose Edit>Clear to remove Patch #8.

Figure 109: Clearing a Patch in the Patch Document Window

Look at the Patch Chain Window. Notice that Patch #8 has disappeared from the 
Patch Document List. Notice that the Patch Chain List still references the missing 
patch, but indicates that the patch has been removed.

Figure 110: Patch Chain after Deleting a Patch

USING A PATCH CHAIN

To use the Patch Chain, you must define a connection using a Patch 
Chain Controls module in the Program Change Sources Window. 
See Chapter 4: Program Change Sources for details.

? NETWORKING NOTE: If using multiple interfaces, Opcode recom-
mends you connect all MIDI devices defined as Patch Chain control 
sources to the same interface. The reason is that each microproces-
sor (whether it’s in the Macintosh or an interface) has its own 
concept of the current location in the Patch Chain. If you use different 
devices connected to different interfaces to advance a Patch Chain, 
you may get unexpected results.
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USING THE
“CHANGING

PATCHES SETS
CURRENT STEP”

CHECK BOX

There may be times that you want to interrupt a pre-determined 
Patch Chain to use a different patch. The check box for “Changing 
Patches Sets Current Step” determines how changing a patch affects 
your position in the Patch Chain.

If the check box for “Changing Patches Sets Current Step” is 
unchecked, then the current Patch Chain step will be unaffected by 
changing patches. Any manual patch changes will not affect the cur-
rent Patch Chain step. This could be useful if, in a live performance, 
you want to deviate from your pre-determined sequence and then 
return to the Patch Chain exactly at the point you left.

If “Changing Patches Sets Current Step” is checked, then the current 
Patch Chain step will jump to the next step that matches the new 
patch. If the newly selected patch isn’t contained in the Patch Chain, 
then the Patch Chain step does not change. This could be useful if, in 
a live performance, you want to jump around within your Patch 
Chain to change the order of your performance.

The following table illustrates how various changes affect the cur-
rent Patch Chain step with and without the “Changing Patches Sets 
Current Step” option checked.

Assume your Patch document contains the following patches: 1 2 3 4 5 6 7 8

and that your Patch Chain is as follows: 2 5 6 4 8 6. THEN...

If you current 
Patch Chain 
step is:

And you 
change the 
patch to:

Then, when you 
advance the 
Patch Chain with 
“Changing 
Patches Sets 
Current Step” 
checked, your 
chain advances to 
step:

When you 
advance the 
Patch Chain with 
“Changing 
Patches Sets 
Current Step” 
unchecked, your 
chain advances to 
step:

2 5 6 4 8 6 8 2 5 6 4 8 6 2 5 6 4 8 6

2 5 6 4 8 6 6 2 5 6 4 8 6 2 5 6 4 8 6

2 5 6 4 8 6 6 2 5 6 4 8 6 2 5 6 4 8 6

2 5 6 4 8 6 3 2 5 6 4 8 6 2 5 6 4 8 6
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CH 6: PATCH SEQUENCES

Each Studio Patch can contain a pair of sequences—the Start 
Sequence and the End Sequence. A patch’s Start Sequence is a short 
list of MIDI events sent to various devices when the patch is recalled. 
The patch’s End Sequence is a short list of events sent when a differ-
ent patch is called up.

Start Sequences are very useful for sending program changes, 
system exclusive patch data, initial controller values, or note off 
commands to a device when a patch is selected. End Sequences are 
often used, when leaving a patch, to undo the effects of the start 
sequence.

? NOTE: Sequence events are sent one immediately after another. 
They do not contain timing information.

CREATING/EDITING PATCH SEQUENCES

a Select a patch by clicking its selector dot.

b Choose Windows>Edit Patch Start Sequence or Windows>Edit Patch End 
Sequence.

The Sequence Edit Window opens.

Figure 111: Start Sequence Edit Window
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The seven buttons across the top of the Sequence Edit Window rep-
resent different MIDI events. These are, from left to right: Program 
Change, Control, Mono Aftertouch, Poly Aftertouch, Pitch Bend, 
System Exclusive, and All Notes Off.

Figure 112: Sequence Event Buttons

Click each button and an undefined corresponding event appears in 
the space below the Module Palette.

Figure 113: Undefined Start Sequence Events

Clicking a sequence event’s selector dot selects that event. Shift-
clicking sequence events selects more than one event for cutting, 
copying, or clearing. Sequence events can be rearranged by option-
clicking their selector dots and dragging them to new locations.

EDITING EVENTS You define and edit most MIDI events by choosing MIDI destina-
tions and MIDI control numbers from pop-up menus. Select MIDI 
channels and event values by their corresponding numericals.

PROGRAM CHANGE EVENTS

Program change events show up as numbers, names, or both. You 
can change the patch by clicking on it and choosing a new one from 
the Patch pop-up. For instructions on getting names to show up, see 
Chapter 7: The Names Window.

Figure 114: Patch Change Event

Control

Poly Aftertouch

System Exclusive

Program Change

Mono Aftertouch

Pitch Bend

All Notes Off
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If the device isn’t subscribed to a Patch Name document via the 
Name Manager, you will be able to click on the rightmost part of the 
patch line to display the following pop-up menu:

Using this menu you can access the five different types of patch 
change messages. The different types allow you to change patches 
on synths that access more than 128 patches via bank select mes-
sages, or multiple program change messages. In all cases, there will 
be numericals next to the boxed icons that you can set to the appro-
priate values. If you are using the Name Manager to provide patch 
names, you won’t need to set the numericals manually; they are 
filled in automatically whenever you select a patch.

Here are the five types of patch change messages:

• PC: Sends a program change message only.
• PC PC: Sends two program changes in rapid succession. Some 

synths use the first message to set the hundreds digits and the 
second message to set the tens and ones digit. For example, PC 105 
PC 38 would set the channel to program 538.

• B0 PC: Sends a bank select (controller) 0 message followed by a pro-
gram change.

• B32 PC: Sends a bank select (controller) 32 message followed by a 
program change.

• B0 B32 PC: Sends a bank select 0 message, a bank select 32 message, 
and a program change.

Check your synthesizer’s documentation to find out what sort of 
patch change message(s) it requires.
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THE SYSTEM EXCLUSIVE EVENT

To edit a system exclusive event:

a Click the area to the right of the “F0” icon to open an Edit Event Window.

Figure 115: Empty Edit Event Window

b Type in the desired hexadecimal data.

Figure 116: Entering Data Into Edit Event Dialog

c Click the close box to return to the Sequence Edit Window. The data is displayed 
in the MIDI Event column.

Figure 117: Sequence Edit Window w/SysEx Event Defined

You may enter any MIDI event into the system exclusive edit dialog. 
System exclusive data must be four bytes or more and end with F7. 
Non-system exclusive data must start with a value between 80 and 
FF (except F5 which is reserved) and it must be three bytes or less.
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You can paste system exclusive data from the Mac Clipboard. If you 
have a large string of system exclusive data (like a patch dump), it 
can be copied to the Clipboard from within Vision (or Studio Vision) 
and then pasted into the Edit Event Window.

? NOTE: System Exclusive messages in a Start or End Sequence 
should always be sent directly to the intended device. Sending 
SysEx to a Virtual Instrument containing a splitter module and differ-
ent devices thickens the MIDI data stream unnecessarily. Sending 
SysEx to a Virtual Instrument consisting of a splitter module routed to 
different channels of the same device may corrupt the data.

VIEWING
SEQUENCE EVENT

TYPES

You can move the cursor over a sequence event in a Sequence Edit 
Window and see the event type’s name displayed. This makes it 
easier to edit long Start or End Sequences.

Figure 118: Viewing a Sequence’s Event Type

You will also see the event name displayed when you move the 
cursor over any of the sequence event buttons.

SENDING ALL NOTES OFF EVENTS

OMS does not automatically send note off commands when you 
change patches. If you hold notes and change patches, any devices 
not used in the new patch will not receive note off commands. This is 
useful in live performance for changing patches while sustaining 
chords or synth pads. If you wish any held notes to turn off when 
you change patches, you should send an All Notes Off event in a 
Patch End Sequence. 

1. Move the cursor over an event, and...
...2. the type of event is diplayed, here.
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There are two ways to send an All Notes Off event to your devices: 
use the MIDI All Notes Off command or use the All Notes Off but-
ton. If your device responds to the MIDI All Notes Off command, 
insert a Control Patch Sequence event, and select Control 123. If your 
device does not respond to the MIDI All Notes Off command, you 
should use the All Notes Off button—this sends actual note off com-
mands to all 128 MIDI notes on the specified channel (and, 
consequently, takes a couple more seconds).

PATCH SEQUENCE EXAMPLE

Let’s assume, for example, that you’re performing in a live situation 
and need to define Patch #2 as a MIDI “stack” that combines a mod-
ulated vibe sound from the ProMaker/1 with a soft organ sound 
from the Vectorific.

DEFINING THE
START SEQUENCE

a Define the patch using the techniques discussed in previous chapters.

You must now define a Start Sequence that sets the ProMaker/1 and Vectorific to 
the proper sounds, volumes and modulations.

b Choose Patch>Edit Patch Start Sequence to open a Start Sequence Edit 
Window.

Assume that the ProMaker/1 has Patch #12 defined as a Vibe sound.

c Click the Program Change sequence event button to place an undefined Program 
Change sequence event in the edit area.

d Choose the ProMaker/1 from the Destination pop-up menu.

Figure 119: Selecting a Destination Device
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e Select Patch #12 as the Program Change number from the MIDI Event pop-up 
menu.

Figure 120: Selecting a Program Change Number

f Click the Control sequence event button, choose the ProMaker/1 as the 
destination, the Mod Wheel as the MIDI Event and 127 as its value. This sets the 
vibe sound’s modulation to full value.

Figure 121: Setting a Control Event

g Choose the desired organ patch for the Vectorific and set each synthesizer’s 
volume level using MIDI Volume Control.

The final start sequence would look as shown in Figure 122.

Figure 122: Fully Defined Start Sequence

Now, whenever you recall Patch #2, your Masterman-88 keyboard 
will control a stack that combines the ProMaker/1 (Channel 1, 
Patch #12 with full modulation and volume) with the Vectorific 
(Channel 1, Patch #63 and a MIDI volume level of 40).
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DEFINING THE END
SEQUENCE

You’ll need to create an End Sequence to undo the effects of the Start 
Sequence. The End Sequence will play whenever you recall a patch 
other than Patch #2.

To create an End Sequence:

a Choose Patch>Edit Patch End Sequence to open an End Sequence Edit 
Window.

b Define Program Change and Control events to undo the effects of the patch’s Start 
Sequence.

Figure 123: Fully Defined End Sequence

The End Sequence shown in Figure 123 will reset the ProMaker/1 
and Vectorific to Patch #0, their volumes to 127, and the ProMaker/
1’s Mod Wheel value to zero whenever you select a different Studio 
Patch.
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CH 7: THE NAMES WINDOW

Choosing Windows>Device Patch Names opens the OMS Name 
Manager.

The Name Manager integrates patch documents from a variety of 
sources:

• Galaxy Bundles
• Studio Patch documents
• Typed-in Patch Name documents
• Documents from other OMS-2 compatible librarians

Once you set up the Name Manager, the Studio Patches Editor’s 
pop-up menus display the names of your synthesizer patches, not 
just their numbers. The Name Manager also takes care of the house-
keeping involved when you open a file that uses a different set of 
patch names.

TERMINOLOGY

Every MIDI device manufacturer seems to use different terminology 
to describe similar features in their devices. For example, different 
synthesizer manufacturers use the terms “patch,” “voice,” “part,” 
“program,” or “sound” to mean the same thing—a collection of pro-
grammable parameters that work together to create a unique sound.

Because Opcode has no way of knowing which MIDI devices you 
own, we must describe certain Name Manager functions generically. 
The following mini-glossary lists the terms we’ll use in describing 
the Name Manager.

PATCH A collection of parameters in a device that define the sound played 
when recalled. For example, one patch might create a trumpet sound 
and another might create a guitar sound.
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BANK A collection of patches stored in a MIDI device. Most modern MIDI 
devices have storage for hundreds (or even thousands) of different 
patches. However, the MIDI specification only provides patch 
change messages for 128 patches. In order to access more than 128 
patches, a device must store them in banks, which are accessed via 
bank select messages. The actual bank select messages vary from 
device to device.

MODE The state of a device that determines how MIDI program changes are 
interpreted. 

Imagine a synthesizer with three different modes:

• Patch Mode: Individual sounds, such as “Electric Piano,” “Acoustic 
Guitar,” or “Flute.”

• Effect Mode: Effects programs such as “Hall Reverb,” “Slap Delay,” 
or “Flange.”

• Performance Mode: A combination of several individual sounds 
with an effects patch, such as an “Electric Piano” patch layered with 
a “Flute” patch and assigned to a “Hall Reverb” effect.

Usually devices access the different modes by interpreting patch 
change messages differently for different channels. For instance, 
General MIDI devices have “patch” channels and “drum” channels. 
Sending program change #1 to a channel in “patch mode” calls up a 
piano, whereas sending program change #1 to a channel in “drum 
mode” calls up a standard drum kit.

By using different device modes, OMS applications can display and 
select any patch type contained in your MIDI device.

Do not confuse modes with banks; a bank of patches for one mode 
might contain an entirely different number of patches than a bank 
for a different mode.

PATCH NAME
DOCUMENT

A document that stores and provides patch names and device modes 
for one or more devices. There are subtle differences in the way the 
Name Manager handles different types of document; these will be 
noted throughout the rest of this chapter.

CURRENT PATCH
NAME DOCUMENT

If a Patch Name document is current, OMS thinks that the patches in 
the document are loaded into the device. You can manually make a 
document current, or a librarian program like Galaxy might auto-
matically do it for you when sending sounds to a device.
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PATCH NAME
PROVIDER

An application that can create a Patch Name document readable by 
the OMS Name Manager.

NAME SETUP A mapping that associates each MIDI device in your current OMS 
Studio Setup document with a specified Patch Name document. 
There is only one Name Setup active at a time, and it “lives” inside 
OMS, not the application.

Since the Name Setup is handled by OMS, changes made to the 
Name Setup in one application affect the names seen in other OMS 
2.0-compatible applications.

When you save a Studio Patches document, the current Name Setup 
is saved along with it.

NAME SETUP WINDOW

To open the Names Window, choose Windows>Device Patch 
Names in the Studio Patches Editor application.

Figure 124: Anatomy of the Names Window

NAMES WINDOW
ANATOMY

As you can see in Figure 124, the Names Window contains numer-
ous elements:

A Device column: This column shows the name of each MIDI device 
contained in your current OMS Studio Setup document. You cannot 
edit the contents of this column. Its contents change whenever the 
current Studio Setup document changes.
Devices stored in a Name Setup but not defined in the current Studio 
Setup appear in italics.

A B C
D

E
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B Patch Name Document column: This column shows the Patch 
Name document referred to by each of the devices. For more infor-
mation, see Patch Name Document Column (pg. 77).

C Device Mode column: If a device supports multiple modes, then this 
column shows which mode it is using. You can change the mode 
directly in this column’s pop-up menu.

D MIDI Channel column: Some MIDI devices let you select different 
modes on different MIDI channels. This column shows which MIDI 
channel uses the mode shown in the Device Mode column. For more 
information, see Channel and Device Mode Columns (pg. 80).

E Name Setup control: Use this pop-up menu to determine how 
changes made in other applications affect the Name Setup. For more 
information, see Name Setup Control (pg. 80).

The information contained in this window is saved with the Studio 
Patches document when using the File>Save or File>Save As 
commands.

The following sections discuss the Names Window in greater detail.

PATCH NAME
DOCUMENT

COLUMN

Use this column to select which Patch Name document is referenced 
by each MIDI device. This is called subscribing to a document. To 
subscribe to a Patch Name document:

a Click in the Patch Name Document column next to a MIDI device.

b Select Names>Subscribe.

A standard Open dialog box appears.

c In the following dialog, navigate to and select the desired Patch Name document. 
Then click OK.

The column now shows the Patch Name document to which you subscribed.

? NOTE: If you don’t know where to find Patch Name documents, read 
the following section.
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WHERE TO FIND PATCH NAME DOCUMENTS

There are three sources for Patch Name documents:

• The Name Manager recognizes Bundles created by Galaxy and other 
OMS-2.0 compatible librarians as Patch Name documents.

• You can create your own “typed-in” Patch Name documents directly 
from the Name Manager.
To do so, double-click in the Patch Name column to open the Patch 
Name Editor. Use the Patch Name Editor to create or edit a Patch 
Name document as described in Patch Name Editing (pg. 84).

Figure 125: Blank Patch Name Editor Window

• Opcode supplies a collection of “factory” Patch Name documents for 
many popular synthesizers. If there is a factory Patch Name docu-
ment for your device, choosing Names>Use Factory/GM Names 
enables it. See Use Factory/General MIDI Names (pg. 82).
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CURRENT AND MISSING DOCUMENTS

Figure 126: Name Setup showing current and missing documents

The Patch Name Document column displays additional information 
about subscribed documents by using italicized text and the small 
diamond icon:

• A small diamond appears before the name of each current Patch 
Name document. A current Patch Name document is the document 
that the Name Manager uses to supply names to all OMS 2.0-com-
patible applications. For more information, see Name Setup Control 
(pg. 80). 
In Figure 126, the MU80’s Patch Name document is not current. This 
means that the patches actually resident in the MU80 don’t match 
those currently subscribed.

• The Patch Name document is italicized if the Name Manager can’t 
locate the document. In Figure 126, the document for the 
Wavestation SR is missing.
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NAME SETUP
CONTROL

Since the OMS Name Manager only references one Name Setup at a 
time, changes made to the Name Setup in other applications can 
affect the Studio Patches Editor. Use the Name Setup control to 
determine what happens when changes are made to the Name 
Setup:

• Always use current patches: Making Patch Name documents cur-
rent in another application changes the Name Setup in the Studio 
Patches Editor to match.

• Keep using these patches: “Locks in” the current Name Setup. Sub-
scriptions can’t be changed in the Studio Patches Editor by changing 
them in another OMS 2.0-compatible application.

This setting is not remembered between sessions. Whenever you 
reopen the Studio Patches Editor, the control is reset to Always use 
current patches.

CHANNEL AND
DEVICE MODE

COLUMNS

The Channel and Device Mode functions are interrelated and are 
described here together.

If a device supports multiple device modes, then the Device Mode 
column contains a pop-up menu listing all possible modes.

Since each MIDI channel can access a different device mode, the Ch 
(Channel) column displays which MIDI channels access which 
device modes. You can view every enabled MIDI channel or just a 
summary of all MIDI channels by clicking the desired device’s selec-
tor icon, then choosing Names>Show Channels.

Name Setup control

Device mode pop-up list
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Show Channels is a toggle whose value is changed by choosing it 
repeatedly.

• When Show Channels is checked (on), the Names Window displays 
a separate row for every MIDI channel in that device (as assigned in 
the OMS Studio Setup document). You can then select a device mode 
for each MIDI channel.

• When Show Channels is not checked (off), the Names Window dis-
plays a single row for that MIDI device and the Ch column is labeled 
all. Changing the device mode affects all channels simultaneously.

Figure 127: Channel mode indicators

EDITING DEVICE MODES WHEN SHOW CHANNELS IS OFF

If Show Channels is off and every MIDI channel is set to the same 
device mode, then that mode appears in the Device Mode column.

Different Device 
Modes assigned 
to different MIDI 
channels

The word various in the 
Device Mode column indi-
cates that not all channels 
are in the same mode.

The word all in 
the Ch column 
indicates that 
Show Channels 
is off.

Same device mode used by 
all MIDI channels
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If Show Channels if off and different MIDI channels use different 
device modes, then the device mode column displays various, indi-
cating more than one device mode is active for this device (see 
Figure 127).

EDITING PATCH NAME DOCUMENTS FOR MULTI-MODE DEVICES

If different MIDI channels reference different device modes, there is 
only one way to edit each mode’s Patch Name document:

a Double-click a number in the Ch column.

A Patch Name Editor opens for that MIDI channel’s mode. Patch Name Editing is 
discussed in Patch Name Editor Anatomy (pg. 85).

? IMPORTANT: This is the only way to edit the patch names for a 
device with multiple modes.

NAMES MENU

The Names Menu is available whenever a Names Window is active.

Figure 128: Name Window Menu

The following sections describe each command in the Names Menu.

SUBSCRIBE This command selects a Patch Name document to which all selected 
devices are subscribed.

USE FACTORY/
GENERAL MIDI

NAMES

If you’re using a General MIDI synth, choose this command to sub-
scribe to the General MIDI Patch Name document located in the 
Factory Names folder (in the OMS Folder inside the System Folder).
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OMS also provides Factory Name documents for many popular 
instruments. If your device is supported, this command subscribes to 
these names.

If the device doesn’t have an associated Factory Name file, the Gen-
eral MIDI patch names are used instead.

COPY
SUBSCRIPTION

This command copies the subscription for the selected device(s) to 
the Clipboard.

PASTE
SUBSCRIPTION

This command pastes subscriptions from the Clipboard onto the 
selected device(s). Any previous subscription is replaced and the 
new Patch Name document becomes current.

CLEAR
SUBSCRIPTION

Removes the subscription information from selected device(s).

MAKE CURRENT When choosing this command, the following alert appears:

Clicking Don’t Make Current retains the previous subscription.

If the Send the patches option is available and checked, the Name 
Manager attempts to transmit the patches to the device when you 
click the Make Current button. The application that created the 
Patch Name document must be capable of this operation. For exam-
ple, names obtained from a Galaxy Bundle can be sent (if Galaxy is 
available on your system), but typed-in name documents cannot and 
the Send the patches option won’t appear in the alert.

USE CURRENT
INSTEAD

Use Current Instead replaces the selected device(s)’ non-current 
subscriptions with subscriptions to the current Patch Name 
document(s).

NEW PATCH
DOCUMENT

Creates a blank, untitled Patch Name document for the selected 
device(s).
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VIEW / EDIT
PATCH NAMES

Selecting a device and choosing this command is equivalent to 
double-clicking a device’s Patch Name document column.

TELL PATCH
PROVIDER

This menu item contains a sub-menu listing the commands that can 
be sent to the Patch Name Provider.

If the Patch Name Provider understands the selected message, it per-
forms that action. For example, if patch names come from a Galaxy 
Bundle and Send Patches To Device is the selected command, 
Galaxy sends the bundled patches to the selected device.

SHOW CHANNELS Show Channels controls whether the Names Window displays one 
row per MIDI channel or a single row representing all MIDI chan-
nels. To assign different device modes to different MIDI channels, 
this option must be enabled (checked). For more information, see 
Channel and Device Mode Columns (pg. 80).

PATCH NAME EDITING

Use the Patch Name Editor to display or edit Patch Name 
documents.

OPENING THE
PATCH NAME

EDITOR

To open a Patch Name Editor:

a In the Names Window, double-click in the Patch Name Document column next to a 
device.

Figure 129: Double-click to open a Patch Name Editor
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A Patch Name Editor opens for that Patch Name document. The Editor shows all 
the Patch Names for that device.

Figure 130: Typical Patch Name Editor

If you open a Patch Name Editor for an unsubscribed device, a blank Patch Name 
Editor opens, which you may use to create a Patch Name document. Documents 
created this way are called “Typed-In” Patch Name documents.

? NOTE: If a Patch Name document contains multiple device modes, 
the Patch Name Editor displays names only for the selected chan-
nel’s current device mode. For more information, see Channel and 
Device Mode Columns (pg. 80).

PATCH NAME
EDITOR ANATOMY

Figure 130 shows the various elements in the Patch Name Editor. 
These are:

A MIDI Program Number: The MIDI column in the Patch Name 
Editor displays MIDI representations of patches in the form bank0/
bank32/patch number (0-127). For example, if the current bank 
requires a bank32 message with value “1” to be sent to access the 
patches, each patch will have “1/x” as its program number, where x 
is the number within the bank.
bank0 and bank32 are each omitted when not used, which is the case 
for the default first bank. Consult your synthesizer’s documentation 
to determine how bank0 and bank32 messages affect patch selection.
These numbers can’t be changed directly, and if the Patch Name doc-
ument comes from an external librarian, they can’t be changed at all. 
If the document in question is a Typed-In Patch Name document, the 
numbers are affected by settings in the Bank Select/Numbering 
dialog box. See Bank Select/Numbering (pg. 92).

A B C D E F

G
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B Device Program Number: This column shows how the MIDI 
device’s internal program numbering corresponds to the actual MIDI 
program number.
For example, some devices number their internal programs 1-128, 
which corresponds to MIDI programs 0-127. This results in the pat-
tern shown in Figure 131 in the MIDI and Numbers column.
The device shown in this example, organizes its programs in banks 
of 50, which are numbered 0-49.

Figure 131: MIDI and device numbering

C Patch Name: This column shows the name of each patch. New patch 
names can be typed directly into this column if this Patch Name doc-
ument was created in the Name Manager (i.e. Galaxy and other 
librarian documents can’t be edited from here). These names appear 
wherever patch names are seen in any OMS 2.0-compatible 
application.

D GM Equivalent: If this patch corresponds to a General MIDI patch, 
choose the relevant GM patch from the pop-up menu in this column. 
The Name Manager applies all attributes and benefits of General 
MIDI groupings to that patch.
For example, assume you have a piano sound in your Patch Name 
document, and you assign “GrandPno1” as its GM Equivalent. Then, 
if you choose to display patch names by General MIDI Groups, this 
piano sound appears whenever you ask to see all the piano sounds 
in your MIDI device. For more information about selecting patches 
by General MIDI Group, see Using Patch Groupings (pg. 96).

This column numbers patches as they 
appear in the actual device.
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E Note Name Indicator: The OMS Name Manager can store custom 
MIDI note names along with patch names. Custom note names have 
many uses. For example, names can be assigned to the notes in a 
drum kit patch, causing edit windows to display notes named 
“kick,” or “snare,” instead of “C3” or “D3.”
This column uses a small note icon to indicate that a patch has 
custom note names. The Note Name Editor can be opened by 
double-clicking in this column. For more information, see Note and 
Control Names (pg. 93).

F Control Name Indicator: The OMS Name Manager allows storage of 
custom MIDI control names along with the name of the patch. 
Custom control names have many uses. For example, a MIDI effects 
device might use MIDI control numbers to edit its internal parame-
ters. By entering custom control names, edit windows display 
controls named “Reverb Time,” or “Pre-Delay,” instead of “Control 
48,” or “Control 37,” making it easier to edit these devices within 
OMS 2.0-compatible applications.
This column indicates that a patch has custom control names if it 
contains a small knob icon. The Control Name Editor can be opened 
by double-clicking in this column. For more information, see Note 
and Control Names (pg. 93).

G Program Selector Dot: If you are pasting names into a typed-in 
name document, you can select the range where the names will be 
pasted by shift-clicking or dragging over the Program Selector Dots. 
If no dots are selected, names are pasted starting at the top and 
working down until the names on the Clipboard are exhausted. See 
Paste Name List (pg. 89) for more information.

PATCHES MENU The Patches Menu is available whenever a Patch Editor is active.

Figure 132: Patches Menu
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? NOTE: Most of these menu items apply only to typed-in Patch Name 
documents; they’re disabled for Patch Name documents that come 
from other applications, such as Galaxy.

SAVE

Choose this command to save any changes you’ve made to the cur-
rent Patch Name document. If you’ve previously saved a document, 
then the Save command replaces the old document with the new 
version. If you haven’t yet saved the active document, choosing Save 
opens the Save As dialog box, in which you name the document and 
select a location in which to store it.

This command behaves differently depending on where the docu-
ment comes from:

• Typed-In Patch Name documents are saved normally.
• Documents from Galaxy or other OMS-compatible Patch Name pro-

viders are converted to Typed-In Patch Name documents. For this 
reason, the Save command is not available when you are in a librar-
ian’s document. In this situation, only the Save As command is 
available.

SAVE AS

Use this command to save a copy of the active document using a dif-
ferent name. Choosing Save As opens the Save As dialog box, in 
which you name the document and select a location in which to store 
it.

SAVING NOTE / CONTROL NAMES

If Note or Control Names have been added to a document created by 
another application, the Save Note/Control Names command 
becomes available. This command adds the note and control name 
information to the saved Patch Name document.
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COPY NAME LIST

Choose Copy Name List to copy the list of Patch Names from a 
Patch Name document onto the Clipboard.

Names are copied to the Clipboard as text, and can be pasted into 
other applications. For example, you can paste names into a word 
processor or database to format, search, or print name lists. Each line 
is copied as:

Patch Number <tab> Patch Name

PASTE NAME LIST

Choose Paste Name List to copy text from the Clipboard into the 
Patch Name Editor. If the lines of text contain tabs, they are inter-
preted as:

Patch Number <tab> Patch Name

Otherwise, each line of text becomes a patch name. If you have 
access to a scanner and OCR (optical character recognition) software, 
you can scan patch name lists for your synthesizers, convert them to 
word processing files, then paste them into the Patch Name Editor.

If any patches in the Patch Name Editor are selected (that is, their 
selector dots are black), then pasting names overwrites only the 
selected patches. For example, if you have ten patch names on the 
Clipboard, but select only three patches, only the first three names 
on the Clipboard are used (see Figure 133).

Figure 133: Only patches 1-3 will be pasted, regardless of the Clipboard’s contents

CLEAR NAME LIST

This command erases the currently selected name list, should you 
wish to start with a “clean slate.”
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ADD MODE

Choose Add Mode to create an entirely new device mode for the 
document, and open a new window to display it.

REMOVE MODE

Choose Remove Mode to delete the device mode displayed in the 
active window.

MODE NAME

Choose Mode Name to name (or rename) the device mode displayed 
in the active window. The mode name appears on the top line of the 
window.

DEFAULT MODES

Choose Default Modes to open a window in which you select a 
default mode for each channel. Whenever this Patch Name docu-
ment is subscribed, the channels are set to the modes designated in 
this window.

Mode name
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For example: General MIDI devices have two modes: standard and 
drums. Channel 10 is always in drums mode, and all other channels 
are in standard mode. Figure 134 shows the default mode screen set 
up for a General MIDI device.

Figure 134: Default Mode Window

ADD BANK

Choose Add Bank to create a new bank of 128 patches following the 
bank containing the currently selected patch, or at the end of the doc-
ument if there is no selected patch. When you choose this command, 
the Bank Select/Numbering dialog box opens as discussed in Bank 
Select/Numbering (pg. 92).

REMOVE BANK

Choose Remove Bank to delete the bank in which the selected patch 
resides.

? NOTE: If the device has less than 128 patches in a bank, leave the 
unused patches blank—blank patches won’t be displayed in patch 
selection menus and dialog boxes.
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BANK SELECT/NUMBERING

Adding a bank or choosing the Bank Select/Numbering command 
opens the Bank Select/Numbering dialog box:

Figure 135: Bank Select/Numbering dialog box

Figure 135 displays the various elements in the Bank Select/Num-
bering dialog box. Specifically:

A A Bank Select message may be specified by checking one or both of 
the Bank Select checkboxes, and by entering a bank select value in 
the box to the right. Consult your synthesizer’s documentation to 
determine the appropriate values for these boxes.

? IMPORTANT: Each bank must have a unique combination of bank 
select messages. A warning message appears if two banks have the 
same bank select combination.

B If the Automatically number patches in bank option is checked, the 
patches are automatically numbered according to the selected num-
bering convention:

• 0-127: Used for synthesizers with a “0 based” numbering 
convention.

• 1-128: Used for synthesizers with a “1 based” numbering 
convention.

• A11-B88: Used for synthesizers with a “bank based” numbering con-
vention (most Roland devices use this scheme).

1

2

3

4
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C Patch prefixes can be entered in the Prefix box. For example, a synth 
may use banks with names such as “RAM1.” The patches could be 
numbered “RAM1-0” thru “RAM1-127” by entering “RAM1-” in the 
Prefix box and selecting 0-127.

Figure 136: Using the Prefix feature

D If the Assign GM equivalents to all patches option is checked, each 
patch is assigned a General MIDI patch equivalent. This sets each 
patches’ number equal to the GM equivalent. This is useful to config-
ure a bank to match the GM defaults without changing the names.

NOTE AND
CONTROL NAMES

Double-click the Cntls column in the Patch Name Editor to open a 
Control Names Window. Similarly, double-click the Notes column 
to open a Note Names Window.

Figure 137: Note Names Window

Saving note names or control names adds them to the Patch Name 
document, regardless of whether it is typed-in or from another 
application.

End of first bank

Beginning of second bank
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Note names are useful for drum machines or samplers. For example, 
it’s easier to edit MIDI data for a drum machine if notes appear 
named “Kick” or “Snare” rather than “C2” or “D2.” Similarly, if 
you’re using a sampler to trigger sound effects, notes named 
“Crash” or “Gunshot” are more useful than notes named “G3” or 
“D5.”

Control names are useful if you perform real-time edits to synthe-
sizer or effects patches. For example, it’s easier to edit controllers 
named “RevTime” or “HPFiltr” than controllers named “Control 41” 
or “Control 73.”

DEFAULT NOTE AND CONTROL NAMES

At the top of every Patch Name document is a line marked Default. 
You can add a set of default note and controller names to a Patch 
Name document by double clicking in the appropriate column and 
typing names into the Note Names Window or Control Names Win-
dow. These default Names are used for every patch that doesn’t 
specifically override them.

Figure 138: Default Note and Control Names

In Figure 138, there is a set of default Note Names. All the patches in 
this bank use these note names. However, the note icon in the row 
for patch number 2 indicates that it has its own set of Note Names 
that override the defaults.

SELECTING NAMES

Once the various name lists are set up properly, the Studio Patches 
Editor will display names in all appropriate places (such as in Pro-
gram Change events in Patch Start Sequences).

There are two ways to choose names:

• A simple pop-up menu of choices, either sorted alphabetically or 
numerically. This appears when you click on a name field.

Default Note and Control Names row
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• The Name Browser. This is a more sophisticated window where you 
can view names numerically or alphabetically—or even group them 
by keyword or patch type. The Name Browser Window appears 
when you command- or option-click a name field.

Figure 139 shows the pop-up menu that appears when you click on a 
patch name field.

Figure 139: Pop-up Patch Name Menu

NAME BROWSER If you option or shift-click on a name field, the Browser Window 
opens:

Figure 140: Patch Name Browser

The Name Manager sends the necessary command (program 
change/bank select) each time a patch is selected. The By number/
By name radio buttons sort the list by number or name; this is global 
and applies to pop-up menus as well.
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USING PATCH
GROUPINGS

The Grouping pop-up menu allows you to choose a grouping assign-
ment for the current patch document. For example, the General 
MIDI patch names contains the groupings None, General MIDI 
Groups and General MIDI Patches. If you select General MIDI 
Groups from the Grouping pop-up menu, you will be presented 
with this list of groupings in the Browser Window:

Figure 141: General MIDI Groups

Selecting an item from this list narrows the list of available patches to 
show only those patches that belong to the selected group. For exam-
ple, patches in the Piano group include Grand Piano, Brite Piano, 
and so forth.

An additional advantage to using groupings is that patch selection 
menus display their contents hierarchically; that is, arranged by 
group (as shown in Figure 142).

Figure 142: Hierarchical Patch Selection

You can create your own groupings with Galaxy, Opcode’s patch 
librarian application. Also, Galaxy automatically provides groupings 
for certain synthesizers. You cannot create groupings with typed-in 
Patch Name documents.
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BROWSER MENU

Figure 143: Browser Menu

When you use the Name Browser, the menu shown in Figure 143 
becomes available.

SORT BY NUMBER/SORT BY NAME

These commands duplicate the function of the “By Name/By Num-
ber” buttons in the Browser Window.

SHOW PATCHES IN ANY/ALL SELECTED GROUP(S)

With “any selected group” selected, shift-clicking multiple group-
ings in the browser displays patches that belong to any of the 
selected groups (if you have programming experience, think of this 
as the “or” condition).

With “all selected groups” selected, shift-clicking multiple group-
ings in the browser only displays patches that belong to all of the 
groups (programmers can think of this as the “and” condition).

As an example, imagine you have a grouping for “bright” and a 
grouping for “piano.” With “all selected groups” chosen, you would 
see only bright pianos listed, whereas with “any selected group,” 
you would see all bright patches and all piano patches listed 
together.

EDIT SELECTED PATCH

Tells the patch provider to open an edit window for the selected 
patch, if the application supports the command.



Ch 7: The Names Window - 98 - Studio Patches Manual

OPENING FILES WITH DIFFERENT NAME SETUPS

The Studio Patches Editor saves Name Setups in its Patch document 
files. When you open a file that references a different name setup, 
you have to answer some questions to let the Name Manager know 
how you want to handle the different assignments. This section 
walks you through the possible outcomes.

First, you see the following dialog box:

Figure 144: Different Name Setups - first dialog box

You have two choices at this point. The following sections describe 
these choices.

MAKE CURRENT This choice overrides all current Name Setup information with the 
information in the file being opened.

Usually if you want to change subscriptions, you also want to send 
the new patches to your synthesizers, and the Name Manager 
assumes that this is what you want to do. You will see a dialog box 
similar to the following, letting you know that transmission is going 
to start:

Figure 145: “Getting Ready To Send” dialog box

Typed-in patch documents have an asterisk (*) next to their name, 
letting you know that they can’t be sent automatically. You should 
load up your devices with these patches in whatever manner is 
appropriate.
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Documents that can’t be found are displayed in italics.

When you are ready, you can click...

• Send: to send the bundles to the devices.
• Don’t Send: to proceed without sending any data.
• Go Back: to return to the previous dialog box.

DON’T MAKE Clicking Don’t Make leaves the current patches current. However, 
you still have a choice to make: do you want to change the document 
being opened to use the current Name Manager subscriptions, or do 
you want to leave the file alone?

Figure 146: “Don’t Make Current” dialog box

If you click...

• Keep: the document is unchanged.
• Change: the document is updated to use the current Name Manager 

subscriptions. If you save the file without changing its name, any 
record of the old subscriptions is lost.

• Go Back: returns to the previous dialog box.
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CH 8: MENU REFERENCE

This chapter documents each menu item and its function.

FILE MENU

Figure 147: File Menu

NEW PATCH
DOCUMENT

Creates a blank, untitled Patch document.

OPEN Presents a directory dialog box in which you can locate a previously-
saved Patch document to open. If the new document contains a 
name setup that differs from the current name setup, you are asked 
how you want to handle this situation. See Opening Files With Dif-
ferent Name Setups (pg. 98) for more information.

OPEN CURRENT
PATCH DOCUMENT

Automatically finds and opens the current Patch document.

CLOSE Closes the currently open Patch document.

SAVE/SAVE AS Writes the current Patch document to disk. If the document has 
never been saved, Save and Save As both present directory dialog 
boxes, allowing you to choose a folder and name for the new file. If 
the file has already been saved, Save overwrites it without 
prompting.
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SAVE AND MAKE
CURRENT

Like Save (above), only it makes the document current at the same 
time. If the document doesn’t need to be saved, this command 
appears just as Make Current.

PAGE SETUP Opens the Page Setup dialog box for the currently chosen printer.

PRINT Prints a list of the patches in the open Patch document, along with 
their numbers.

EDIT MENU

Figure 148: Edit Menu

UNDO Reverses the previous operation, if possible.

CUT Erases the current selection and puts it on the clipboard (presumably 
for pasting somewhere else).

COPY Copies the current selection to the clipboard.

PASTE Pastes the contents of the clipboard at the selection point, if the data 
is compatible (you can’t, for instance, paste a copied patch into a 
patch’s name field).

CLEAR Erases the current selection completely (you can still undo if you 
make a mistake).

SHOW CLIPBOARD Shows the current contents of the clipboard.
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MOVE UP Moves the selected item up the screen. Useful for rearranging patch 
lists or the patches themselves, to group similar entries together, for 
example.

MOVE DOWN Moves the selected item down the screen.

OMS STUDIO
SETUP

Opens the OMS Setup application. See the OMS manual for a 
detailed description of this program.

OMS MIDI SETUP Opens the OMS MIDI Setup dialog box. See the OMS manual for a 
detailed description of this dialog box.

ALL NOTES OFF
(PANIC)

Sends an “All Notes Off” message to every channel of every device 
on every interface. Useful for getting rid of stuck or hung notes.

PATCH MENU

Figure 149: Patch Menu

NEW PATCH Choose New Patch to add a new empty patch to the Patch docu-
ment. Each Patch document can hold up to 128 patches.

EDIT PATCH Choose Edit Patch to open a Patch Edit Window. This is the same as 
double-clicking a patch selector dot in the Patch Document Window.

RECALL PATCH Choosing Recall Patch is the same as clicking in a patch’s diamond 
column. It makes the selected patch the current patch. After choosing 
Recall Patch, you will see a diamond next to the patch number to 
indicate that it is the current patch.

SORT BY PATCH
NUMBER

Choose the Sort by Patch Number command to view your Patch 
document in numerical order. When the command is enabled 
(checked), patches will always be displayed in numerical order. 
When the command is unchecked, patches can be in any order.
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REBUILD ALL Choose this command to rebuild all your patches. You will need to 
use Rebuild All only if your patches, virtual controllers, virtual 
instruments or program change sources aren’t working, and the 
device menus in the appropriate windows don’t contain italicized 
choices. This situation is most likely to occur if you switch between 
two very similar Studio Setups (for example, one with a Studio 4 on 
the modem port, and another with the same devices, but with the 
Studio 4 on the printer port).

SOLO Mutes all destinations in a patch except for the currently selected 
one(s).

UNSOLO Unmutes all selected destinations in a patch.

WINDOWS MENU

Figure 150: Windows Menu

EDIT VIRTUAL
CONTROLLERS

Choose Edit Virtual Controllers to open the active Patch docu-
ment’s Virtual Controllers Edit Window. Choosing this menu item is 
the same as clicking the Virtual Controllers button in the Patch Doc-
ument Window. Virtual controller editing is discussed in Chapter 3: 
Virtual Controllers and Virtual Instruments.

EDIT VIRTUAL
INSTRUMENTS

Choose Edit Virtual Instruments to open the active Patch docu-
ment’s Virtual Instruments Edit Window. Choosing this menu item 
is the same as clicking the Virtual Instruments button in the Patch 
Document Window. Virtual Instrument editing is discussed in 
Chapter 3: Virtual Controllers and Virtual Instruments.
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EDIT PROGRAM
CHANGE SOURCES

Choose Edit Program Change Sources to open the active Patch doc-
ument’s Program Change Source Edit Window. Choosing this menu 
item is the same as clicking the Program Change Sources button in 
the Patch Document Window. Virtual Instrument editing is dis-
cussed in Chapter 4: Program Change Sources.

EDIT PATCH CHAIN Choose Edit Patch Chain to open the active Patch document’s Patch 
Chain Edit Window. Choosing this menu item is the same as clicking 
the Patch Chain button in the Patch Document Window. Patch 
Chains are discussed in Chapter 5: Patch Chains.

DEVICE PATCH
NAMES

This command opens the OMS Name Manager. See Chapter 7: The 
Names Window for more information.

EDIT PATCH START
SEQUENCE

Choose this item to open a Patch Start Sequence Edit Window for the 
selected patch. For information on editing and using Start 
Sequences, see Chapter 6: Patch Sequences.

EDIT PATCH END
SEQUENCE

Choose this item to open a Patch End Sequence Edit Window for the 
selected patch. For information on editing and using End Sequences, 
see Chapter 6: Patch Sequences.

CONTROLLERS
FOR MIDI EDITING

Choose Controllers for MIDI Editing to produce a dialog contain-
ing a list of all devices defined in your current Studio Setup 
document. In the dialog, select those devices you wish to use for 
MIDI entry of patch edit parameters.
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CH 9: PATCH IDEAS

This chapter contains some ideas on how to apply the various fea-
tures of Studio Patches, and also some troubleshooting tips.

MIDI MERGING

An individual patch can contain more than one MIDI routing. As an 
example, let’s say that you (operating your Masterman-88 keyboard 
controller) and your drummer (playing his new GeoSkin MIDI per-
cussion pads) both want to control the same Vectorific sound 
module patch from your individual controllers. This is a classic 
example of MIDI merging.

a Choose Patch>New Patch and create a Studio Patch with the Masterman-88 as 
the MIDI source and the Vectorific module as the MIDI destination.

b Click the MIDI Source module icon and create a second connection below the first.

c Choose the GeoSkin drums as the MIDI source and the Vectorific as the MIDI 
destination.

Figure 151: MIDI Merging Patch

With this patch, both the Masterman-88 keyboard and the GeoSkin 
drums will play MIDI Channel 1 of the Vectorific module.
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BAND ROUTINGS

You can route your entire band through your MIDI interface. For 
instance, you could have the MIDI Tuba playing the Digiwhiz 2000, 
the GeoSkin drum pads playing the Banger Man II drum module, 
and the Masterman-88 keyboard playing a ProMaker/1 stacked with 
a Vectorific. This configuration would have a Patch Edit Window 
similar to the one shown in Figure 152.

Figure 152: A Band Routing Patch

STUDIO 5 FOOTSWITCH IDEAS

The Studio 5’s two footswitches (FS1, FS2) and one foot controller 
(FC1) can be used as controllers in a Studio Patch. To use the foot-
switches or foot controller in a patch, simply choose the Studio 5 as 
your MIDI source.

VOLUME PEDAL A simple volume pedal is created in the following example. The 
Masterman-88 controls MIDI Channel 1 of the Vectorific synth mod-
ule. The foot controller (FC1) controls the volume of the Vectorific.

Figure 153: Volume Pedal

? NOTE: Make sure that Studio 5>Foot Controller In is checked 
(enabled) in the OMS Setup application so that Foot Controller infor-
mation is recognized. Foot Controller status is saved within the 
Studio 5’s internal memory.
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IMPROVED
VOLUME PEDAL

You can improve upon the above example by adding an Event Type 
Filter module. Use the filter to pass only Opcode foot controller data 
from the Studio 5 to the Vectorific as shown below. This prevents 
MIDI Time Code, if it’s in use, from being sent to the Vectorific—
thus thinning the MIDI data stream.

Figure 154: Improved Volume Pedal

VIRTUAL PEDALS As another example, assume that you want to use the Studio 5 foot 
controller (FC1) as a volume pedal, and a Studio 5 footswitch (FS1) 
as a sustain pedal. Using Virtual Controllers is the easiest and most 
efficient way to handle this task.

a Choose Patch>Edit Virtual Controllers or click the Virtual Controllers button in 
the current Patch Document Window to open the Virtual Controllers Edit Window.

b Design a Virtual Controller similar to the one shown in Figure 155. 

See Chapter 3: Virtual Controllers and Virtual Instruments to learn about Virtual 
Controllers and Virtual Instruments.

Figure 155: Defining Virtual Pedals
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You can then use these Virtual Controllers in any patch, without 
worrying if they are sending MIDI Time Code to your MIDI output 
devices. The following example illustrates the use of these Virtual 
Controllers in a patch where the Masterman-88 plays Channel 1 of 
the Vectorific while the Studio 5’s foot controller controls Vectorific 
volume and the Studio 5’s FS1 acts as a sustain pedal.

Figure 156: Using Virtual Pedals

EXPRESSIVE INSTRUMENTS

You can use velocity switching to trigger different sounds—the trig-
gered sound depends on the note-on velocity. Velocity switching can 
add greater dynamic realism to instruments, or provide startling 
special effects. You can design patches to perform velocity switching 
if your synthesizers don’t offer it. Even if your synthesizers do offer 
velocity splitting, Studio Patches provide the additional advantage 
of velocity switching between different devices.

Assume, for example, that your Vectorific sound module has a nice 
pianissimo piano sound, and that the Digiwhiz 2000 sampler has 
good mezzo-forte piano and forte piano sounds. Build a patch simi-
lar to the one shown in Figure 157.

Figure 157: Velocity Switching

Notice that a soft touch plays the Vectorific piano sound, medium 
playing triggers a mezzo-forte piano sound on the Digiwhiz 2000 
(Ch. 1), and banging on the keys plays a forte piano sound on the 
Digiwhiz 2000 (Ch. 2).
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ONE FINGER CHORDS

To ease the pressure during a live performance or to compensate for 
a short reach, you can use splitters and transposers to build one-
finger chords.

The patch example shown in Figure 158 produces a minor ninth 
chord from just one note. 

Figure 158: One Finger Chord

If you hit a C, then your sound module would produce the chord 
shown in Figure 159.

Figure 159: Cm9 Chord

BANK SELECTION

You can use the Start and End Sequences to send bank select mes-
sages to your synthesizers. For each bank in your synthesizer, simply 
design a Studio Patch that recalls and plays that bank.
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The Patch document shown in Figure 160 contains 10 different 
patches for playing the Matrix-1000 synthesizer. Each patch contains 
a Start Sequence with a system exclusive event that selects and locks 
a Matrix-1000 bank. The End Sequence unlocks the bank when you 
leave the patch.

Figure 160: Studio Patch Selects Matrix-1000 Bank

STUDIO PATCH PROBLEMS

A MIDI SOURCE OR DESTINATION MODULE CONTAINS A QUESTION MARK

Question marks indicate undefined modules. Click anywhere to the 
right of the question mark to open a pop-up menu of MIDI devices 
as defined in your current Studio Setup document. See Chapter 2: 
Patch Modules for more details.

ONE OR MORE MIDI DEVICES DO NOT APPEAR IN THE MIDI SOURCE 
POP-UP MENU

The MIDI device is being used elsewhere within the same patch as a 
MIDI source.
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PATCHES DON’T WORK—MIDI SOURCE OR DESTINATIONS ARE 
ITALICIZED

You probably have a Patch document that was created with a Studio 
Setup document other than the one that is now current. Either make 
the other Studio Setup document current, make another Patch docu-
ment current, or re-select any italicized MIDI Source or Destination 
modules in the current patch and save it. See Chapter 1: Studio 
Patches Introduction for more information.

PATCHES DON’T WORK—MIDI SOURCE OR DESTINATIONS ARE NOT 
ITALICIZED

Choose Patch>Rebuild All to rebuild patches.
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	d Insert a Simple Splitter module between the Virt...
	e Add a second MIDI Destination module by clicking...
	f Choose the K2000 from the upper MIDI Destination...
	g Click the Virtual Instrument module to select it...
	h Type in the name of your new Virtual Instrument ...
	i Close the Virtual Instruments Edit Window.
	? NOTE: System Exclusive messages should always be...
	Using Virtual Instruments with Vision
	OMS applications such as Vision and Studio Vision ...
	Figure 71: Studio Setup Document Example
	Figure 72: Virtual Instrument Example


	a Launch Vision.
	b Choose Windows>Instruments.
	c Choose New Instrument from the Instruments menu....
	Figure 73: Adding an Instrument in Vision

	d Choose “HippoStack” from the MIDI Output Device ...
	Figure 74: Selecting a MIDI Output Device in Visio...

	e Choose Channel 2 from the MIDI Output Channel po...
	Figure 75: Newly Defined Instrument in Vision

	f Click on the Thru Instrument setting at the left...
	Figure 76: Choosing a Virtual Instrument in Vision...

	g Choose “HippoStack-2.”
	  You wish to play a sequence using an interesting...
	  You wish to have a sound made up of several chan...
	Creating Virtual Instruments from Existing Patches...
	a Open the Patch Edit Window for the patch you wan...
	b Select every part of the connection except the M...
	c Choose Edit>Copy.
	d Open the Virtual Instruments Edit Window.
	e Click the Virtual Instrument module icon, then c...
	f In the new connection, click the MIDI Destinatio...
	g Click the MIDI Destination module icon, then mov...
	h Choose Edit>Paste to paste the contents of the c...
	i Type a name into the Virtual Instrument module a...




	Ch 4: Program Change Ch 4: Sources
	  Change Studio Patches from a MIDI controller.
	  Change Studio Patches from a MIDI controller onl...
	  Step through a pre-determined Patch Chain using ...
	Opening a Program Change Sources Edit Window
	Figure 77: Program Change Sources button
	Figure 78: Empty Program Change Sources Window

	Program Change Sources Edit Window Terminology
	Figure 79: Anatomy of a Program Change Sources Win...

	MIDI Source Module
	Figure 80: MIDI Source Module
	a Click the MIDI Source module icon. The cursor wi...
	b Click in the blank space below the Module Palett...
	c Choose a MIDI source from the MIDI Source module...
	d Use the Channel numerical to set a MIDI transmis...

	Change Studio Patches
	Figure 81: Change Studio Patches Module
	Figure 82: Adding a Change Studio Patches Module
	Editing the Change Studio Patches Module
	Figure 83: Change Studio Patches Module Edit Windo...


	Enable Studio Patch Changes Module
	Figure 84: Enable Studio Patch Changes Module
	a Add a new MIDI Source module to the Program Chan...
	Figure 85: Adding a Second Connection

	b Choose a MIDI Source and channel, then place an ...
	Figure 86: Defining Studio Patch Change Enabling S...
	Editing the Enable Studio Patch Changes Module
	Figure 87: Enable Studio Patch Changes Module Edit...
	Figure 88: Example of an Studio Patch Change Conne...


	? NOTE: Remember that Studio�5 footswitch and foot...
	Using a Single Studio Patch Change and Enable Sour...
	Assume, for example, that you wanted to send Studi...
	Figure 89: Single Studio Patch Change and Enable S...




	Patch Chain Controls Module
	Figure 90: Patch Chain Controls Module
	Figure 91: Adding a Patch Chain Controls Module
	Editing the Patch Chain Controls Module
	a Double-click the Patch Chain Controls module to ...
	Figure 92: Patch Chain Controls Module Edit Window...

	b Choose (from the Forward pop-up menu) the MIDI c...
	c Choose (from the Backward pop-up menu) the MIDI ...
	? NETWORKING NOTE: If you’re using multiple interf...


	Ch 5: Patch Chains
	Opening a Patch Chain Edit Window
	Figure 93: Patch Chain Button
	Figure 94: Empty Patch Chain Edit Window

	Patch Chain Edit Window Terminology
	Figure 95: Anatomy of a Patch Chain Edit Window
	A Insert Patch Chain Steps Button
	B Patch Document List
	C Patch Chain List (each item in the list is calle...
	D Selector Dot
	E Insertion Point

	Creating a Patch Chain
	a Click the selector dot of a patch in the Patch D...
	Figure 96: Select Patch from Patch Document List

	b Click the Insert Patch Chain Steps button to ins...
	Figure 97: Click Patch Chain Steps Button

	? SHORTCUT: Double-click a selector dot in the Pat...
	Selecting Multiple Patches
	a Shift-click two or more patches in the Patch Doc...
	Figure 98: Shift-Clicking Multiple Patches

	b Click the Insert Patch Chain Steps button to ins...
	Figure 99: Inserting Multiple Patches
	Using the “All Patches In Order” Check Box
	Figure 100: Patch Chain before Checking All Patche...
	Figure 101: Patch Chain after Checking All Patches...




	Editing a Patch Chain
	a Click the selector dot next to the Patch Chain S...
	b Choose Edit>Copy.
	Figure 102: Select and Copy a Patch Chain Step

	c Click between Patch Chain Steps to select a new ...
	Figure 103: Defining an Insertion Point

	d Choose Edit>Paste to paste the copied Patch Chai...
	Figure 104: Pasting a Patch Chain Step

	a Copy a Patch Chain Step to the Clipboard as show...
	Figure 105: Copying a Patch Chain Step

	b Paste the Patch Chain Step without choosing an i...
	Figure 106: Pasting to the End of the Patch Chain ...

	? NOTE: If the Insert Patch Chain Steps button is ...

	Changing the Patch Document
	a Look at the Patch Chain Window shown in Figure�1...
	Figure 107: Typical Patch Chain Window

	b Open the current Patch Document Window and selec...
	Figure 108: Selecting a Patch in the Patch Documen...

	c Choose Edit>Clear to remove Patch #8.
	Figure 109: Clearing a Patch in the Patch Document...
	Figure 110: Patch Chain after Deleting a Patch


	Using a Patch Chain
	? NETWORKING NOTE: If using multiple interfaces, O...
	Using the “Changing Patches Sets Current Step” Che...
	There may be times that you want to interrupt a pr...




	Ch 6: Patch Sequences
	? NOTE: Sequence events are sent one immediately a...
	Creating/Editing Patch Sequences
	a Select a patch by clicking its selector dot.
	b Choose Windows>Edit Patch Start Sequence or Wind...
	Figure 111: Start Sequence Edit Window
	Figure 112: Sequence Event Buttons
	Figure 113: Undefined Start Sequence Events
	Editing Events
	Program Change Events
	Figure 114: Patch Change Event



	  PC: Sends a program change message only.
	  PC PC: Sends two program changes in rapid succes...
	  B0 PC: Sends a bank select (controller) 0 messag...
	  B32 PC: Sends a bank select (controller) 32 mess...
	  B0 B32 PC: Sends a bank select 0 message, a bank...
	The System Exclusive Event
	To edit a system exclusive event:

	a Click the area to the right of the “F0” icon to ...
	Figure 115: Empty Edit Event Window

	b Type in the desired hexadecimal data.
	Figure 116: Entering Data Into Edit Event Dialog

	c Click the close box to return to the Sequence Ed...
	Figure 117: Sequence Edit Window w/SysEx Event Def...


	? NOTE: System Exclusive messages in a Start or En...
	Viewing Sequence Event Types
	Figure 118: Viewing a Sequence’s Event Type



	Sending All Notes Off Events
	Patch Sequence Example
	Defining the Start Sequence
	a Define the patch using the techniques discussed ...
	b Choose Patch>Edit Patch Start Sequence to open a...
	c Click the Program Change sequence event button t...
	d Choose the ProMaker/1 from the Destination pop-u...
	Figure 119: Selecting a Destination Device

	e Select Patch #12 as the Program Change number fr...
	Figure 120: Selecting a Program Change Number

	f Click the Control sequence event button, choose ...
	Figure 121: Setting a Control Event

	g Choose the desired organ patch for the Vectorifi...
	Figure 122: Fully Defined Start Sequence
	Defining the End Sequence
	You’ll need to create an End Sequence to undo the ...
	To create an End Sequence:


	a Choose Patch>Edit Patch End Sequence to open an ...
	b Define Program Change and Control events to undo...
	Figure 123: Fully Defined End Sequence



	Ch 7: The Names Window
	  Galaxy Bundles
	  Studio Patch documents
	  Typed-in Patch Name documents
	  Documents from other OMS-2 compatible librarians...
	Terminology
	Patch
	Bank
	Mode
	The state of a device that determines how MIDI pro...
	Imagine a synthesizer with three different modes:

	  Patch Mode: Individual sounds, such as “Electric...
	  Effect Mode: Effects programs such as “Hall Reve...
	  Performance Mode: A combination of several indiv...
	Patch Name document
	A document that stores and provides patch names an...

	Current Patch Name document
	Patch Name provider
	Name Setup


	Name Setup Window
	Figure 124: Anatomy of the Names Window
	Names Window Anatomy
	As you can see in Figure�124, the Names Window con...

	A Device column: This column shows the name of eac...
	B Patch Name Document column: This column shows th...
	C Device Mode column: If a device supports multipl...
	D MIDI Channel column: Some MIDI devices let you s...
	E Name Setup control: Use this pop-up menu to dete...
	Patch Name Document Column
	Use this column to select which Patch Name documen...

	a Click in the Patch Name Document column next to ...
	b Select Names>Subscribe.
	c In the following dialog, navigate to and select ...
	? NOTE: If you don’t know where to find Patch Name...
	Where To Find Patch Name Documents
	There are three sources for Patch Name documents:

	  The Name Manager recognizes Bundles created by G...
	  You can create your own “typed�in” Patch Name do...
	Figure 125: Blank Patch Name Editor Window

	  Opcode supplies a collection of “factory” Patch ...
	Current and Missing Documents
	Figure 126: Name Setup showing current and missing...
	The Patch Name Document column displays additional...


	  A small diamond appears before the name of each ...
	  The Patch Name document is italicized if the Nam...
	Name Setup Control
	Since the OMS Name Manager only references one Nam...


	  Always use current patches: Making Patch Name do...
	  Keep using these patches: “Locks in” the current...
	Channel and Device Mode Columns
	The Channel and Device Mode functions are interrel...
	Show Channels is a toggle whose value is changed b...


	  When Show Channels is checked (on), the Names Wi...
	  When Show Channels is not checked (off), the Nam...
	Figure 127: Channel mode indicators
	Editing Device Modes when Show Channels is Off
	Editing Patch Name Documents for Multi-Mode Device...
	If different MIDI channels reference different dev...

	a Double-click a number in the Ch column.


	? IMPORTANT: This is the only way to edit the patc...


	Names Menu
	Figure 128: Name Window Menu
	Subscribe
	Use Factory/ General MIDI Names
	Copy Subscription
	Paste Subscription
	Clear Subscription
	Make Current
	Use Current Instead
	New Patch Document
	View / Edit Patch Names
	Tell Patch Provider
	Show Channels

	Patch Name Editing
	Opening the Patch Name Editor
	To open a Patch Name Editor:

	a In the Names Window, double-click in the Patch N...
	Figure 129: Double-click to open a Patch Name Edit...
	Figure 130: Typical Patch Name Editor

	? NOTE: If a Patch Name document contains multiple...
	Patch Name Editor Anatomy
	Figure�130 shows the various elements in the Patch...


	A MIDI Program Number: The MIDI column in the Patc...
	B Device Program Number: This column shows how the...
	Figure 131: MIDI and device numbering

	C Patch Name: This column shows the name of each p...
	D GM Equivalent: If this patch corresponds to a Ge...
	E Note Name Indicator: The OMS Name Manager can st...
	F Control Name Indicator: The OMS Name Manager all...
	G Program Selector Dot: If you are pasting names i...
	Patches Menu
	Figure 132: Patches Menu

	? NOTE: Most of these menu items apply only to typ...
	Save
	This command behaves differently depending on wher...

	  Typed-In Patch Name documents are saved normally...
	  Documents from Galaxy or other OMS-compatible Pa...
	Save As
	Saving Note / Control Names
	Copy Name List
	Choose Copy Name List to copy the list of Patch Na...
	Names are copied to the Clipboard as text, and can...

	Paste Name List
	Choose Paste Name List to copy text from the Clipb...
	Figure 133: Only patches 1-3 will be pasted, regar...


	Clear Name List
	Add Mode
	Remove Mode
	Mode Name
	Default Modes
	Figure 134: Default Mode Window

	Add Bank
	Remove Bank


	? NOTE: If the device has less than 128 patches in...
	Bank Select/Numbering
	Figure 135: Bank Select/Numbering dialog box
	Figure�135 displays the various elements in the Ba...



	A A Bank Select message may be specified by checki...
	? IMPORTANT: Each bank must have a unique combinat...

	B If the Automatically number patches in bank opti...
	  0-127: Used for synthesizers with a “0 based” nu...
	  1-128: Used for synthesizers with a “1 based” nu...
	  A11-B88: Used for synthesizers with a “bank base...

	C Patch prefixes can be entered in the Prefix box....
	Figure 136: Using the Prefix feature

	D If the Assign GM equivalents to all patches opti...
	Note and Control Names
	Figure 137: Note Names Window
	Default Note and Control Names
	Figure 138: Default Note and Control Names




	Selecting Names
	There are two ways to choose names:
	  A simple pop-up menu of choices, either sorted a...
	  The Name Browser. This is a more sophisticated w...
	Figure 139: Pop-up Patch Name Menu
	Name Browser
	Figure 140: Patch Name Browser

	Using Patch Groupings
	Figure 141: General MIDI Groups
	Figure 142: Hierarchical Patch Selection

	Browser Menu
	Figure 143: Browser Menu
	Sort by Number/Sort By Name
	Show Patches In Any/All Selected Group(s)
	Edit Selected Patch



	Opening Files With Different Name Setups
	Figure 144: Different Name Setups - first dialog b...
	Make Current
	Figure 145: “Getting Ready To Send” dialog box

	  Send: to send the bundles to the devices.
	  Don’t Send: to proceed without sending any data....
	  Go Back: to return to the previous dialog box.
	Don’t Make
	Figure 146: “Don’t Make Current” dialog box


	  Keep: the document is unchanged.
	  Change: the document is updated to use the curre...
	  Go Back: returns to the previous dialog box.
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	File Menu
	Figure 147: File Menu
	New Patch Document
	Open
	Open Current Patch Document
	Close
	Save/Save As
	Save And Make Current
	Page Setup
	Print

	Edit Menu
	Figure 148: Edit Menu
	Undo
	Cut
	Copy
	Paste
	Clear
	Show Clipboard
	Move Up
	Move Down
	OMS Studio Setup
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	Patch Menu
	Figure 149: Patch Menu
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	Ch 9: Patch Ideas
	MIDI Merging
	a Choose Patch>New Patch and create a Studio Patch...
	b Click the MIDI Source module icon and create a s...
	c Choose the GeoSkin drums as the MIDI source and ...
	Figure 151: MIDI Merging Patch


	Band Routings
	Figure 152: A Band Routing Patch

	Studio�5 Footswitch Ideas
	Volume Pedal
	Figure 153: Volume Pedal

	? NOTE: Make sure that Studio�5>Foot Controller In...
	Improved Volume Pedal
	Figure 154: Improved Volume Pedal

	Virtual Pedals
	a Choose Patch>Edit Virtual Controllers or click t...
	b Design a Virtual Controller similar to the one s...
	Figure 155: Defining Virtual Pedals
	Figure 156: Using Virtual Pedals
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	Figure 157: Velocity Switching

	One Finger Chords
	Figure 158: One Finger Chord
	Figure 159: Cm9 Chord

	Bank Selection
	Figure 160: Studio Patch Selects Matrix-1000 Bank

	Studio Patch Problems
	A MIDI Source or Destination module contains a que...
	One or more MIDI Devices do not appear in the MIDI...
	Patches don’t work—MIDI source or destinations are...
	Patches don’t work—MIDI source or destinations are...




