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OPCODE

 

OMS 2.0 for Windows

 

Opcode publishes on-line documents in two formats: Common 
Ground™ and Adobe Acrobat™. The following sections contain 
basic information about these on-line publications.

 

• Common Ground Documents

 

If you downloaded this document in 
Common Ground (.dp) format, then it uses 
the digital paper format developed by 
No Hands™ software. It includes an imbed-
ded Common Ground mini-viewer, which 
allows you to view the document using the 
various 

 

Page

 

 Menu commands, and to print 
the document by choosing 

 

File>Print

 

.

 

• Acrobat Documents

 

If you downloaded this document in Adobe Acrobat (.pdf) format, 
then use Acrobat Reader’s numerous Toolbar buttons to view and 
print this document. Some of the more common buttons are dis-
cussed below. For more information about Acrobat Reader, see its 
on-line documentation.

Additionally, many Acrobat formatted publications contain hyper-
text links imbedded within the text. Simply click any blue 
underlined text to “jump” to the cross-referenced information.

First Page

Previous Page

Next Page

Last Page
 
View Bookmarks
Select this option to activate a
complete hypertext table of contents
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CH 1: OVERVIEW AND 

 

INSTALLATION

 

INTRODUCTION TO THE OPEN MUSIC SYSTEM™ (OMS)

 

Opcode’s Open Music System (OMS) is a code library that bridges 
the gap between MIDI applications and MIDI hardware. It has many 
functions and features:

 

• OMS acts as a central MIDI driver

 

OMS-compatible applications use OMS to communicate with all of 
your MIDI hardware (such as synthesizers, drum machines, PC 
sound cards, effects devices, or MIDI controllers).

 

• OMS provides a central location for defining and storing a 
detailed description of your MIDI studio

 

Use the OMS Setup application to create a Studio Setup document, 
in which you store a detailed description of the MIDI devices in your 
studio—including their names, their MIDI channels, and how 
they’re all physically connected.
All OMS-compatible applications reference this Studio Setup docu-
ment. So, if you change your studio in any way, simply modify your 
Studio Setup document and all compatible applications are immedi-
ately aware of the change.

 

• OMS provides a patch name management tool

 

Use this tool, appropriately called the Name Manager, to store the 
names of all the patches in your MIDI devices and provide those 
names to your OMS-compatible applications.

 

• OMS handles all your computer’s internal MIDI timing

 

This allows you to run multiple OMS-compatible applications simul-
taneously and in perfect synchronization.
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• OMS gives you access to hundreds of MIDI channels

 

The actual number of MIDI channels that OMS can access depends 
on which MIDI interface(s) you use.
Standard MIDI interfaces (such as a SoundBlaster or Opcode’s 
Note/1) access 16 total MIDI channels. Multiport MIDI Interfaces 
(such as Opcode’s Music Quest 8Port/SE) access 16 MIDI channels 
on each pair of MIDI In/Out jacks. So, for example, since an 8Port/
SE has 8 pairs of MIDI In/Out jacks, it can access 128 total MIDI 
channels.
For more information, see your MIDI interface manuals.

 

ABOUT THIS MANUAL

 

This manual assumes that you’re familiar with basic PC and Win-
dows operations. If you’re not, please read those manuals before 
installing or using OMS.

Also, you should have a basic understanding of MIDI. If you don’t, 
you may wish to purchase one of the many basic MIDI reference 
books available from your local book store or music retailer.

This manual accurately describes OMS operations at the time of its 
printing. However, updates and changes may occur. Always look for 
the latest information in the Read Me files on your master program 
disk.
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This manual does not discuss the Name Manager. Although the 
Name Manager is part of OMS, its services are available only from 
within OMS-compatible applications and not from within the OMS 
Setup application. Therefore, Name Manager information is con-
tained within your OMS-compatible application manuals.

Also, OMS supports a wide variety of MIDI hardware configura-
tions. Because many of these configurations are of interest to a small 
percentage of users, Opcode documents them in special on-line doc-
uments called “Technical Publications.” These publications address 
specific topics not covered in the written manual. 

You can download Technical Publications for OMS (or any other 
Opcode products) from Opcode’s World Wide Web site at:

 

http://www.opcode.com

 

If you don’t have Web access, you can contact Opcode to receive 
Technical Publications through the mail. For more information about 
contacting Opcode, see Contacting Opcode (pg. 6).
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M

 

ANUAL

 

C

 

ONVENTIONS

 

This manual uses a number of conventions that make it easier to dis-
cuss and understand certain on-screen actions.

 

M

 

OUSE

 

 A

 

CTIONS

 

This manual uses the following terms to describe various mouse 
actions:

•

 

Click

 

: When the manual instructs you to “click,” position the mouse 
where you’re told and press once on the mouse button, then immedi-
ately release it.

•

 

Double-click

 

: When the manual instructs you to “double-click,” 
position the mouse where you’re told and rapidly press and release 
the mouse button twice.

•

 

Press and hold

 

: When the manual instructs you to “press and hold,” 
position the mouse where you’re told, press the mouse button and 
hold it down until instructed to release it.

•

 

Release

 

: When the manual instructs you to “release,” let up on the 
mouse button (which you were probably holding down because of 
an earlier “press and hold” instruction).

•

 

Drag

 

: When the manual instructs you to “drag,” position the mouse 
where you’re told, then press the mouse button and hold it down as 
you move the mouse.

•

 

Move

 

: When the manual instructs you to “move” the mouse, simply 
move it to another location on the screen without pressing its button.

 

C
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VS
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ELECT

 

The words “choose” and “select” are often interchangeable in con-
versational English. In this manual, however, there is a distinct 
difference between the two terms.

•

 

Select

 

: When the manual tells you to “select” something, it stays 
selected. This is the case with check boxes and menu options.

•

 

Choose

 

: When the manual tells you to “choose” something, a one-
time action is performed. This is the case with most commands; they 
perform their chosen action only once.
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M

 

ENU

 

 C

 

OMMANDS

 

This manual uses a shorthand technique to invoke various menu 
items. For instance, this manual might say:

“Choose 

 

Studio>New Device

 

.”

What this means in plain English is, “choose the 

 

New Device 

 

com-
mand from the 

 

Studio

 

 menu.” Although the shorthand technique 
results in sub-standard grammar, it’s easier to read and decipher 
than a complete sentence because it displays the menu’s hierarchical 
structure plainly and simply.

 

Figure 1: Shorthand Invocation of Menu Items

 

BEFORE INSTALLING OMS

 

Before you install OMS, you should:

• Connect your MIDI interface or sound cards to your PC (as 
described in those manuals).

• Install all related Windows device drivers (as described in the card 
or MIDI interface manuals).

• Connect your MIDI devices (synthesizers, drum machines, effects 
units) to the MIDI interface, then turn them on.
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INSTALLING OMS

 

There is an installer program on your OMS master disk. To install 
OMS:

 

a

 

Insert the master disk into your floppy drive and run A:SETUP.EXE

If your floppy is drive B, then run B:SETUP.EXE

 

b

 

Answer each question as prompted by the installer application.

The installer places all the necessary OMS files onto your hard disk 
automatically.
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Here is an overview of the OMS file layout:

• The Open Music System software is placed into the Windows folder 
(usually C:\Windows).

• The OMS Setup application is placed inside a folder named 
OMSAPPS.

 

CONTACTING OPCODE

 

To reach Opcode Technical Support:

 

Phone 415-856-3331

(M-F, 9-5 + Sat, 11-5, Pacific Time)

FAX 415-856-0777

FTP ftp.opcode.com

World-Wide Web http://www.opcode.com

E-mail support@opcode.com
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CH 2: CREATING A NEW STUDIO 

 

SETUP DOCUMENT

 

This chapter teaches you to use the OMS Setup application to create 
a new Studio Setup document.

 

WHAT IS A STUDIO SETUP DOCUMENT?

 

A Studio Setup document is an exact model of your MIDI Studio. A 
fully configured Studio Setup document contains information about:

• MIDI interfaces connected either externally (such as an Opcode 
Music Quest 2Port/SE) or internally (such as an MQX-32M).

• MIDI cards installed inside your computer (such as a 
SoundBlaster™).

• Software-based synthesizers and other “Virtual Devices” (such as 
Creative’s FM or AWE synths).

• MIDI devices connected to MIDI interfaces (such as synthesizers, 
drum machines, effects devices, and MIDI controllers).

Additionally, a Studio Setup document contains information about 
how all this hardware is physically connected.

You can create and store any number of Studio Setup documents to 
describe any number of studios or studio configurations, but OMS 
can reference only one Studio Setup document at a time. This is 
called the “current Studio Setup document.”

Once you’ve defined a current Studio Setup document, OMS knows 
each instrument’s name, port, MIDI reception channel(s), Device ID 
and many other details. This information is provided to all OMS-
compatible applications. Within these applications, you simply 
select and work with devices by name—OMS handles the rest. Any 
time you change your current Studio Setup document, OMS auto-
matically provides the updated information to all your OMS-
compatible applications.
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CREATING YOUR FIRST STUDIO SETUP DOCUMENT

 

To create a new Studio Setup document:

 

a

 

If you have not already done so, install your MIDI cards and 
interfaces, connect your MIDI devices to your MIDI interface and turn 
them on.

See your card, interface, and/or MIDI device manuals if you need 
help.

 

You create and modify Studio Setup documents using an application 
called OMS Setup, so...

 

b

 

Find the 

 

OMS Setup

 

 application.

By default, the OMS installer creates a program group (or Start Menu 
group) for Opcode applications and puts the OMS Setup shortcut 
program icon in it.

 

c

 

Run 

 

OMS Setup

 

 to start the program.

After starting the OMS Setup application, you’ll see the dialog box 
shown in Figure 2.

 

Figure 2: Configure OMS Dialog

 

d

 

Click 

 

OK

 

 to proceed.

OMS scans all your installed Windows device drivers.

Then, if you checked the 

 

Auto-detect MIDI devices

 

 option, OMS 
Setup next attempts to automatically identify any MIDI devices capa-
ble of supplying this information—currently only a handful of modern 
devices have this ability.

 

?

 

NOTE: To auto-detect a device, it must have both its MIDI In and 
MIDI Out jacks connected to the interface.
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You’ll see a dialog box asking your to name your new Studio Setup 
document.

 

e

 

Save your Studio Setup document with whatever name you like.

OMS Setup saves the Studio Setup document and displays it on the 
screen.

 

Figure 3: Studio Setup Document
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The example shown in Figure 3 shows a Studio Setup document for 
a PC equipped with a SoundBlaster AWE-32 card and Opcode’s 
8Port/SE MIDI interface.

 

?

 

IMPORTANT: Your Studio Setup document will most likely look dif-
ferent than the one shown in Figure 3 because it’s based on 

 

your

 

 
MIDI hardware.

 

ANATOMY OF THE STUDIO SETUP DOCUMENT

 

Figure 4: Anatomy of a Studio Setup Document

 

Figure 4 shows the various elements contained in a typical Studio 
Setup document. These are:

 

A

 

MIDI interfaces, cards, and software-based synthesizers
The example shown in Figure 4 contains four such devices: The 
“ME8PSE” is the 8Port/SE multiport MIDI interface. The “SB16” is 
the SoundBlaster’s built-in MIDI Interface. The “AWE 32” and the 
“OPL3 FM” are both software-based synthesizers (known as “virtual 
devices”) that come with the SoundBlaster.

A

B

C

D

E
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?

 

NOTE: Notice that a single Creative AWE32 SoundBlaster card 
appears as three distinct devices: the SB AWE32 MIDI Synth; the 
Creative OPL3 FM Synth; and the SB16 MIDI Out (a true MIDI 
interface).

 

B

 

Undefined MIDI devices
Even if you checked the 

 

Auto-detect MIDI Devices

 

 option in the 
Configure OMS dialog box, only the most modern MIDI devices are 
capable of defining themselves to OMS Setup. OMS Setup has no 
way of detecting what other MIDI devices are connected to your 
MIDI interface (or even if any are actually connected). Therefore, it 
creates a generic undefined MIDI device on each MIDI port for 
which it doesn’t auto-detect a device. You can recognize an unde-
fined device by the question mark icon.

 

Figure 5: Undefined MIDI Device Icon

 

In the example shown in Figure 3 (pg. 9), OMS Setup automatically 
created and connected nine undefined MIDI devices to the 8Port/SE. 
Also, since the SoundBlaster can use a special cable to function as a 
standard 1 IN x 1 OUT MIDI interface, a single undefined MIDI 
device is shown connected to it.
Chapter 3: Defining MIDI Devices discusses how to define MIDI 
devices in a Studio Setup document.

 

C

 

MIDI cables (signal flow)
The connecting lines indicate MIDI cables and the arrows indicate 
the signal flow direction.
By default, OMS Setup assumes you have a pair of MIDI cables con-
nected to each undefined MIDI device.
You’ll learn how to modify these connections in the Studio Setup 
document to model your actual MIDI studio in Chapter 4: Connect-
ing Devices in the Studio Setup Document.

D MIDI ports on a multiport MIDI interface
Multiport MIDI interfaces display each of their MIDI ports in the 
Studio Setup document.
By default, if OMS Setup can’t auto-detect a specific MIDI device, it 
creates an undefined MIDI device on each port.
If you have only a standard MIDI interface (such as the SoundBlaster 
shown in Figure 4), then the Studio Setup document won’t contain 
any port numbers for that interface.
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E Current Studio Setup indicator
The current Studio Setup document is indicated by a small “X” to the 
left of its name.

Figure 6: Current Studio Setup Indicator

As discussed in What is a Studio Setup Document? (pg. 7), you can 
create and save any number of Studio Setup documents, each of 
which may reflect different studio configurations (or even different 
studios). But OMS can reference only one Studio Setup document at 
a time—this is called the “current Studio Setup document.”

A current Studio Setup document 
contains an “x” to the left of the docu-
ment’s name.

Non-current Studio Setup document 
does not contain the “x”



Ch 3: Defining MIDI Devices OMS 2.0 for Windows — pg. 13

CH 3: DEFINING MIDI DEVICES

In this chapter, you’ll learn how to define the MIDI devices in your 
Studio Setup document so that they accurately represent the hard-
ware in your MIDI studio.

DEFINING AN UNDEFINED MIDI DEVICE

If the current Studio Setup document isn’t already open, choose 
File>Open Current Studio Setup, then follow through these steps to 
learn how to define a MIDI device in your Studio Setup document.

a Click an undefined MIDI device to select it (highlighting it).

b Choose Studio>MIDI Device Info.

Alternately, you could simply double-click a MIDI device icon.

OMS Setup opens a MIDI Device Info dialog box for the selected 
MIDI device.

selected MIDI 
device has a high-
lighted border
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Figure 7: MIDI Device Info Dialog Box

DEFINING THE

MANUFACTURER

AND MODEL

You’ll first want to define the MIDI device’s manufacturer and 
model number. To do so:

a Click the Manuf arrow button to open its drop-down list box, then 
select the manufacturer of the MIDI device (as shown in Figure 8).

Figure 8: Select a Manufacturer
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b Click the Model arrow button to open its drop-down list box, then 
select the model of the MIDI device.

Figure 9: Select a Model

OMS Setup automatically fills in the Name field with the model’s 
name. You can type in a different name if you desire.
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DEFINING THE MIDI
CHARACTERISTICS

You’ll next want to define the MIDI characteristics of the selected 
device.

Figure 10: MIDI Characteristics

Figure 10 shows the various MIDI characteristics contained in the 
MIDI Device Info dialog box. These are:

A Is controller check box
Check this check box if your MIDI device is a MIDI controller (such 
as a keyboard, MIDI guitar, MIDI drum pads, and so on).
This check box is automatically set when you define a Manufacturer 
and Model, but you can override the default setting.

B Is multitimbral check box
Check this check box if your MIDI device is multitimbral.
Multitimbral means that the device is capable of receiving MIDI data 
on more than one channel. Most modern synthesizers are multitim-
bral—many early MIDI synthesizers are not.
This check box is automatically set when you define a Manufacturer 
and Model, but you can override the default setting.

A
B

D

C

E
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C MIDI Receive Channels
Check all the MIDI channels on which your MIDI device receives 
MIDI data.
For example, if your synthesizer is set up to receive only on MIDI 
channels 1 through 6, check only the boxes numbered 1 through 6.
If the Is multitimbral check box is not checked, your device can 
receive on only one MIDI channel, so you can check only one box at 
a time.

D Device ID
Set the Device ID numerical to match the Device ID setting on your 
MIDI device.
If the Is multitimbral check box is not checked, the Device ID is 
automatically set to match the MIDI Receive Channel. You can enter 
a different Device ID number if you wish.
See your MIDI device manual to learn how to view (or change) its 
Device ID.

E MIDI Synchronization check boxes
Check the MIDI Time Code check boxes only if: 1) your MIDI device 
sends or receives MIDI Time Code, and 2) you intend to use it to syn-
chronize that MIDI device to your OMS-compatible MIDI sequencer.
Check the MIDI Beat Clock check boxes only if: 1) your MIDI device 
sends or receives MIDI Beat Clock, and 2) you intend to use it to syn-
chronize that MIDI device to your OMS-compatible MIDI sequencer. 
Many drum machines and synthesizers with built-in sequencers are 
able to send and receive MIDI Beat Clock.
Check the MIDI Machine Control check boxes only if: 1) your MIDI 
device sends or receives MIDI Machine Control, and 2) you intend to 
use it to synchronize that MIDI device to your OMS-compatible 
MIDI sequencer.
See your MIDI device manuals to learn whether or not they support 
any of these synchronization methods.
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ASSIGNING A
DEVICE ICON

When you select a Manufacturer and Model, OMS Setup automati-
cally assigns an icon to that MIDI device. To select a different icon:

a Click the icon in the upper left corner of the MIDI Device Info dialog 
box.

The Device Icon dialog box appears.

Figure 11: Device Icon Dialog Box

b Click a different icon in this dialog box, then click the OK button.

? NOTE: You can open the Device Icon dialog box directly from the 
Studio Setup Window. To do so, simply click the device’s icon to 
select it, then choose Studio>Device Icon.

Click here to open the 
Device Icon dialog box
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FINISHING THE

DEFINITION

When you’ve finished defining a MIDI device, click the OK button in 
the MIDI Device Info dialog box.

Your Studio Setup document now contains a fully defined MIDI 
device, complete with the device’s name and icon.

Figure 12: Studio Setup Document with a Defined MIDI Device

DEFINING

ADDITIONAL MIDI
DEVICES

Repeat all the steps discussed in Defining an Undefined MIDI 
Device (pg. 13) until you’ve defined every MIDI device in your stu-
dio, then choose File>Save to save your Studio Setup document.

DELETING MIDI DEVICES

If your Studio Setup document contains MIDI devices that aren’t in 
your actual MIDI studio, you can delete them from the document.

This is particularly useful for:

• removing undefined devices created by the OMS Setup application.
OR...

• removing devices no longer contained in your MIDI studio.

Defined MIDI Device
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To remove the unused MIDI devices from your Studio Setup 
document:

a Click a MIDI device to select it (highlighting it as shown in Figure 13).

Figure 13: Selecting an Unused MIDI Device

b Choose Edit>Delete.

OMS Setup removes the MIDI Device from your Studio Setup 
document.
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c Continue this process for all remaining, unused MIDI devices.

Figure 14: Studio Setup Document with No Undefined MIDI Devices

ADDING MIDI DEVICES TO A STUDIO SETUP DOCUMENT

Sometimes you’ll need to add a MIDI device to your Studio Setup 
document. To do so:

a Choose Studio>New Device.

OMS Setup opens the MIDI Device Info dialog box.
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b Configure the dialog box as discussed in Defining an Undefined MIDI 
Device (pg. 13).

OMS Setup creates a new device and automatically adds it to the top 
of your Studio Setup document.

Figure 15: New, Unconnected MIDI Device

? NOTE: If an interface or MIDI device is selected (highlighted) when 
you choose the Studio>New Device command, OMS Setup auto-
matically attaches the new device to the selected device, rather than 
adding it to the top of the Studio Setup document.

Chapter 4: Connecting Devices in the Studio Setup Document will 
tell you how to connect MIDI devices together in a Studio Setup 
document.

Newly created MIDI device
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CH 4: CONNECTING DEVICES IN 
THE STUDIO SETUP 
DOCUMENT

In this chapter, you’ll connect all the MIDI devices in your Studio 
Setup document to mirror the way the actual hardware is connected 
in your studio.

When you finish connecting device icons, your Studio Setup docu-
ment will function as a graphic representation of the MIDI 
components in your studio.

? IMPORTANT: The Studio Setup document should reflect, as accu-
rately as possible, the actual connection of MIDI devices in your 
studio. OMS-compatible applications derive their knowledge of the 
devices in your studio from the Studio Setup document.

CONNECTING MIDI DEVICES TOGETHER

To “connect” MIDI devices together in a Studio Setup document, 
simply drag one device icon onto another.

Using this technique, you can connect...

• MIDI devices to MIDI interfaces, as discussed in Connecting Devices 
to a MIDI Interface (pg. 24).

• MIDI devices to other MIDI devices. This technique is used when 
“daisychaining devices using MIDI Thru jacks, as discussed in Using 
MIDI Thru Ports (pg. 28).

• MIDI patchbays to MIDI interfaces, as discussed in Using MIDI 
PatchBays (pg. 33).

• MIDI devices to MIDI patchbays, as discussed in Using MIDI Patch-
Bays (pg. 33).
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CONNECTING

DEVICES TO A MIDI
INTERFACE

Assume you have a 1-in x 2-out MIDI interface, and that you defined 
two MIDI devices, one of which was added to the top of your Studio 
Setup document (as shown in Figure 16).

Figure 16: Studio Setup Document with Unconnected Device

To connect the Proteus/2 to your MIDI interface:

a Move the cursor over the Proteus/2 icon, then press and hold the 
mouse button.

The MIDI device becomes highlighted.

b While still holding the mouse button, drag the cursor over the MIDI 
interface icon.

Notice, when you drag, that the cursor becomes a “drag cursor.” 

The MIDI interface becomes highlighted.

Unconnected Device

Highlighted MIDI Device

Highlighted MIDI Interface
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c Release the mouse button.

OMS Setup “connects” the MIDI device to the MIDI interface.

Figure 17: Studio Setup Document Shows Both MIDI Devices 
Connected to the MIDI Interface

CONNECTING AND DISCONNECTING MIDI CABLES

The last step in defining your Studio Setup document is to connect or 
disconnect MIDI cables to reflect the actual cabling in your real MIDI 
studio.

The Studio Setup document represents each connected MIDI device 
with a pair of lines running in and out of its left side. These lines rep-
resent MIDI cables and the arrows indicate the direction of MIDI 
data flow.

To “disconnect” a cable in a Studio Setup document, simply click its 
directional arrow. To reconnect a cable, click it again.

Figure 18: Disconnecting/Connecting Cables

These arrows represent the 
direction of MIDI data flow

These lines 
represent 
MIDI cables

Click here to disconnect 
or connect a MIDI cable
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PRACTICAL

EXAMPLE

Figure 19 contains a 1-in by 2-out MIDI interface. Obviously this 
Studio Setup document is wrong—the MIDI interface contains only 
one MIDI In jack, yet the Studio Setup document shows two synthe-
sizers sending MIDI data to the interface.

Figure 19: Incorrect MIDI Cabling

The actual MIDI studio has the K2000’s MIDI Out jack connected to 
the MIDI interface and both device’s MIDI In jacks connected to the 
MIDI interface. To modify your Studio Setup to show the correct 
connection:

a Click the MIDI Out arrow to the left of the Proteus/2.

OMS Setup removes the cable from the Studio Setup document. 
Your Studio Setup document now accurately reflects the cabling in 
your MIDI Studio.

This document shows TWO MIDI cables connected to the 
interface’s single MIDI In port—obviously an incorrect 
representation.
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DISCONNECTING MIDI DEVICES

If you disconnect a device in your actual studio, you should also dis-
connect it in your Studio Setup document. To do so:

a Click both directional arrows to the left of the MIDI device you wish to 
disconnect.

OMS Setup disconnects the MIDI device and moves it to the top of 
the Studio Setup document.

This is better than deleting the device because it remains in your 
Studio Setup document. Then, if you reconnect the device at a later 
date, you need only re-connect it in the Studio Setup document, as 
well.

Click both directional 
arrows to disconnect a 
MIDI device

Disconnected device is moved to 
the top of the Studio Setup 
document
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CH 5: SPECIAL STUDIO SETUP 
TECHNIQUES

USING MIDI THRU PORTS

Most MIDI devices have a MIDI Thru port, which passes along any 
MIDI data received on the device’s MIDI In port. MIDI Thru ports let 
you “daisy-chain” MIDI devices. In a Studio Setup document, you 
represent Thru port connections by connecting one MIDI device to 
another.

THRU EXAMPLE 1 Assume you have two MIDI devices connected as shown in 
Figure 20.

Figure 20: Daisy Chained MIDI Devices

IN OUT

Korg M1

THRUIN OUT

Kurzweil K2000

THRU

INOUT

1 x 1
Interface

To PC
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To create this connection in a Studio Setup document:

a Drag the M1 icon on top of the K2000.

OMS Setup connects the M1 to the K2000 indicating a “Thru” 
connection.

b Click the M1 MIDI Out arrow to disconnect it.

Your Studio Setup document now accurately reflects the cabling in 
your actual MIDI studio.

Drag this icon...

...onto this one.

Cable coming from bottom indi-
cates a MIDI Thru connection.
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THRU EXAMPLE 2 Assume you have two MIDI devices connected as shown in 
Figure 21.

Figure 21: Alternative MIDI Daisy Chain

To create this connection in a Studio Setup document:

a Drag the M1 icon on top of the K2000 icon, then disconnect the 
K2000’s MIDI output.

Your Studio Setup document looks like this:

b Click the M1 icon to select it (highlighting it).

c Choose Studio>Different In/Out Ports.

OMS Setup creates a MIDI loop with a MIDI plug.

IN OUT

Korg M1

THRUIN OUT

Kurzweil K2000

THRU

INOUT

1 x 1
InterfaceTo PC

MIDI plug

MIDI loop
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d Drag the MIDI plug onto the MIDI interface icon.

OMS Setup creates the Studio Setup document shown in Figure 22, 
which now accurately reflects the MIDI connections shown in 
Figure 21.

Figure 22: Correct Studio Setup Document

USING MIDI MERGERS

A MIDI merger combines the MIDI outputs of two different MIDI 
devices into a single MIDI output.

For example, assume your studio has a 1-in x 2-out MIDI interface 
and that you have two MIDI keyboard synthesizers. Without a MIDI 
merger, you could connect only one of your keyboard’s MIDI out-
puts to your computer.

Drag this MIDI plug...

... over the Interface icon.
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Figure 23: M1 cannot be used as a MIDI Controller

This results in the following Studio Setup Document:

By using a MIDI merger, you could combine the outputs of both key-
boards, so that either could be used as a MIDI controller.

Figure 24: Connecting a MIDI Merger
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To indicate the use of an external MIDI merger in the Studio Setup 
document, simply connect the MIDI outputs from both merged 
devices to the MIDI interface as shown in Figure 25.

Figure 25: Studio Setup Indicates Use of a MIDI Merger

Notice that both the K2000 and the M1 can send MIDI data to the 
interface. The MIDI merger does not appear in the Studio Setup doc-
ument, but its function is represented by the two MIDI cables 
coming from the two MIDI devices.

USING MIDI PATCHBAYS

A MIDI patchbay (sometimes called a patcher, switcher, or thru box) 
is an external box that contains numerous MIDI In/Out jacks, which 
allows you to connect many MIDI devices to a single MIDI interface.

Figure 26: Studio With MIDI Patchbay
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Figure 27 shows a Studio Setup document for the MIDI studio 
shown in Figure 26.

Figure 27: Studio Setup with MIDI Patchbay

ADDING A MIDI
PATCHBAY TO THE

STUDIO SETUP

DOCUMENT

This section discusses how to configure a Studio Setup document 
using a MIDI patchbay. More detailed instructions are in a separate 
Technical Publication at Opcode’s Web site.

a Choose Studio>New Patcher.

The Patcher Info dialog box appears.
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b From the drop-down list boxes, select the manufacturer and model of 
your MIDI patchbay.

You can select “other” if you don’t see your patchbay in the list.

c Use the Ports numerical to enter the number of MIDI ports (In/Out 
MIDI jack pairs) on your MIDI patchbay.

OMS Setup enters the number automatically when you select a 
known patchbay from the Manuf and Model drop-down lists.

d Using the Receive Channels check boxes, select the MIDI channel 
on which your patchbay receives MIDI program change information.

e Click the OK button.

OMS Setup adds the MIDI patchbay to the top of your Studio Setup 
document.

f Drag the patchbay icon onto the MIDI interface icon to connect it.

g Drag MIDI devices onto the patchbay icon to connect them.

Figure 28 shows the anatomy of a typical MIDI patchbay connection.

Figure 28: MIDI Patchbay Anatomy

h Set the ports and program numbers to mirror your MIDI patchbay’s 
actual operation (as discussed below).

Briefly:

• MIDI Patchbay Port Numbers: These numericals correspond to the 
numbered ports on your MIDI patchbay. For example, if your Korg 
M1 is connected to port 3 of your MIDI patchbay, set the numerical 
next to the M1 to “3”.

MIDI Patchbay Port Numbers
Program Numbers

Default Program
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• Default Program: Every MIDI patchbay needs one internal program 
that’s designed to 1) transfer MIDI data from any MIDI controller to 
your PC, and 2) transfer MIDI data from the PC to every MIDI 
device. This is called the “default” program. Set the Default Program 
numerical to match the MIDI program number of the patchbay’s 
internal “default” program.

• Program Numbers: You should program your MIDI patchbay such 
that each MIDI device has its own patchbay program that sends 
MIDI data only to that device and receives MIDI data only from that 
device. Set each Program Number numerical to match the MIDI pro-
gram number that does this in the patchbay’s internal memory.

? IMPORTANT: See the Technical Publication named “Using OMS 
with a MIDI Patchbay” for detailed information about patchbay pro-
gramming, Studio Setup configuration, and using multiple MIDI 
patchbays.

USING MULTIPORT MIDI INTERFACES

A multiport MIDI interface is basically a MIDI interface and patch-
bay in a single box. A classic example is the Opcode Music Quest 
8Port/SE.

Figure 29: Studio With Multiport MIDI Interface
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Figure 30 shows a Studio Setup document for the MIDI studio 
shown in Figure 29.

Figure 30: Studio Setup with Multiport MIDI Interface

Make sure you set the MIDI Port numericals to mirror the physical 
ports used on your MIDI interface. For example, if your M1 is con-
nected to Port 5 on the 8Port/SE, set the M1’s MIDI Port numerical 
to “5” in the Studio Setup document.

CREATING A “DO

NOTHING” PATCH

If you use a programmable multiport MIDI interface, it’s important 
to program a “do nothing” patch into its internal memory. Since 
MIDI sequencing programs perform their own MIDI routing and 
thruing operations, your multiport interface needs a program that 
does NO internal MIDI routing of its own—this is called the “do 
nothing” patch.

MIDI Port Numericals
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For example, a “do nothing” patch in the 8Port/SE would look as 
shown in Figure 31.

Figure 31: 8Port/SE’s “Do Nothing” Sequencing Patch

Notice that only the computer is used to transfer MIDI data between 
devices—there are no internal MIDI routings defined.
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CH 6: TESTING YOUR STUDIO 
SETUP DOCUMENT

OMS Setup provides a test mode to check the accuracy of your 
Studio Setup document.

ENTERING TEST MODE

To enter test mode:

a Choose File>Open Current Studio Setup if your current Studio 
Setup document is not active.

b Select Studio>Test Studio.

The Test Studio command toggles test mode on and off. When test 
mode is active, the Test Studio option will have a check next to it. 
Also, the cursor in the Studio Setup document will change to an 
eighth note when it’s over a MIDI device or interface icon. 

TESTING PC-TO-MIDI DEVICE CONNECTIONS

To test the flow of MIDI data from the PC into each of your MIDI 
devices:

a Click a MIDI device icon with the note cursor.

This sends random notes to the device on the MIDI channels on 
which the device receives. To make sure the notes are audible, a 
MIDI volume message sets every channel’s volume to 127. Listen for 
a cacophony of notes (or watch your device’s MIDI indicator LED).

TESTING MIDI DEVICE-TO-PC CONNECTIONS

To test MIDI data flow from MIDI devices into the PC, each device 
must be able to generate MIDI data. On controller instruments just 
strike a key, pluck a string or hit a pad. When the PC receives the 
MIDI data, the line connecting the two devices blinks.
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? NOTE: If your Studio Setup contains MIDI merging (multiple sources 
into one port), the wrong arrow may flash when testing MIDI connec-
tions from devices connected to the merger. When MIDI arrives from 
a merged source, only one of them is going to flash, and it won’t nec-
essarily be the one that really sent the data.

For devices that have no keyboard, the best way to test MIDI data 
flow to the PC is to initiate a bulk dump from that MIDI device.

EXITING TEST MODE

a Choose Studio>Test Studio to turn-off OMS Setup’s test mode.
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